Second Generation Nissan Xterra Forums banner

1 - 20 of 30 Posts

·
on line
Joined
·
192 Posts
Discussion Starter · #1 ·
So, have you ever been sitting in your X and wondered what it looked like behind your dash?



Actually, i bought a theft recovery X and the wiring harness was all cut up, so i am replacing it with a brand new one. After getting some good deals on ebay on interior parts i should have a 2005 X with 22k miles on it for 11k :cheers:

While pulling out all the parts i am thoroughly cleaning them and it should be nice once its all back together. Assembly pictures to follow. If you have questions, let me know. I am thinking of doing a writeup of the assembly/dissassembly when i have all the parts together.
 

·
on line
Joined
·
1,479 Posts
sweet, I want to see those assembly images
 

·
on line
Joined
·
1,208 Posts
I was totttaly thing this last night wehn trying to find my in cabin filert systme. i had my head in there and was like, whoa, I wonder what else is in there? and look at that metal bar, its like a roll cgae in my dash. (im kinda drunk and lazy so im not QC'ing my typing. lol.


cant wait to see (read) the wrtitre up on this,
 

·
on line
Joined
·
192 Posts
Discussion Starter · #8 ·
Well, i finally got the new harness in from the dealer, probably the most expensive part of this rebuild so far. But the money invested here is worth it to get a brand new harness. I got it all installed and planned to take more pictures, but my frustration got in the way of my documentation.

Replacing the harness was simple and just took time, start to finish running the new harness through the old harness's spot took about an hour. A little longer than i planned, but was putting the new harness in the exact same spot as the old harness.

here is a picture showing the nice new connections, a far cry from what i started with.



My frustration started when I started reassembling the interior in the wrong order, the main dash piece goes on first and then the lower piece with the 4x4 switch. I put the center console and glove box on before i put in the 4x4 switch so it all had to come back out.



After you get those 3 parts in (main dash, center console, and 4x4 switch) you can put in the tachometer.



Then put in the HVAC control piece. Thanks to 'lowhombre' i will soon have a radio to stick in there



After the hvac piece is in the cluster lid goes on



The piece below the cluster lid, arrived yesterday, thanks to a 15 dollar auction on ebay. It is installed and pics to come.

Surprises after everything was altogether:

4 blown fuses that had to be replaced

air bag light is on, coolant light is on, tire pressure light is on, service engine soon light is on.

Car started right up, didnt even turn over more than once.

3/4 tank of gas in the vehicle :cheers:

Its really hot in utah, and i should have picked a better time of day besides noon to install.



Other than that, this project has been to simple and cheaper than i planned. Left over money will be used for the shrock rear bumper and sliders. Oh yeah, door panels are in the works (the wife doesnt like the extra rugged look right now)
 

·
on line
Joined
·
8 Posts
Quick question, was the vehicle originally an SE? Or are you adding SE parts to an S? Noticed the guage cluster and saw one on ebay. Was thinking of swapping my S's cluster to the SE's and seeing if I could get the trip computer to work. Plus I like the bright rings. Good job so far though!
 

·
on line
Joined
·
192 Posts
Discussion Starter · #11 ·
D ROCK said:
Quick question, was the vehicle originally an SE? Or are you adding SE parts to an S? Noticed the guage cluster and saw one on ebay. Was thinking of swapping my S's cluster to the SE's and seeing if I could get the trip computer to work. Plus I like the bright rings. Good job so far though!
I believe the Vehicle was an S, but swapping in the other gauge cluster was kind of a gamble. I believe that 'Dragonplayboy' also swapped his non-silver ringed cluster for a silver ringed one.

So far there have been no issues with the guage cluster, it works fine, but only has the air bag light on due to the air bag module missing.

Honestly it was the first gauge cluster that i came across on ebay that was 4wd, so i bought it :) Maybe i should change my name to FrankenX?
 

·
on line
Joined
·
971 Posts
Those pics sure look like rust there. I remember another member complaining about the rust issue to his dealer. I have yet to check if I have rust in my X yet.
 

·
on line
Joined
·
192 Posts
Discussion Starter · #13 ·
hollywoodstylin said:
Those pics sure look like rust there. I remember another member complaining about the rust issue to his dealer. I have yet to check if I have rust in my X yet.
Yeah the car was in NY when i bought it, and being that close to the coast i expect it to have a little rust. In utah i am sure the process will be slowed down substantially. In most cars that i have seen this seems to eventually happen, although mine seems to be excessive due to its life on the coast and being exposed without the dash on it.
 

·
on line
Joined
·
1,320 Posts
no matter where you are you'll get rust like that on the unseen metal... it's just light surface rust due to it just being bare steel (no coating).
It's normal and is nothing to be concerned with.
 

·
on line
Joined
·
142 Posts
maybe a dumb question but if you swap the gauge cluster from a base X to one from an SE will the trip computer, gas mileage, miles till empty, etc. just work? Or is there mods that need to be made to make them work?
 

·
on line
Joined
·
8 Posts
yeah, was gonna ask the same question about the SE cluster in an S and if the trip computer was operational. when your X is up and running, would love to find out how it turned out...
 

·
on line
Joined
·
971 Posts
travis,

how are you going to synchronize the mileage on the gauge cluster with the actual mileage of the X? Are you taking it to the dealer to get it reprogrammed? If you're doing it yourself, can you put together a how-to for that particular section of your rebuild?
 

·
on line
Joined
·
192 Posts
Discussion Starter · #19 ·
D ROCK said:
yeah, was gonna ask the same question about the SE cluster in an S and if the trip computer was operational. when your X is up and running, would love to find out how it turned out...
Driven it around a bunch of times and everything seems to be operational. I still havent registered it due to air bag issues, so long trips arent possible.
 

·
on line
Joined
·
192 Posts
Discussion Starter · #20 ·
hollywoodstylin said:
travis,

how are you going to synchronize the mileage on the gauge cluster with the actual mileage of the X? Are you taking it to the dealer to get it reprogrammed? If you're doing it yourself, can you put together a how-to for that particular section of your rebuild?
The cluster i bought has 33k on it, and supposedly my X has 22k, I am not to concerned about the mileage since 'odometer fraud' is already on the title, due to it being sold without a cluster.

Can i program this thing? I guess that only makes sense since dealerships have to anticipate replacing gauge clusters, I will look into it, and report what i can find out.
 
1 - 20 of 30 Posts
Top