Second Generation Nissan Xterra Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all: I'm getting spotty reception in my 2013 XTerra. Factory installed equipment.

I'd like to troubleshoot this but can't find the factory satellite antenna (or where it would even be installed on the vehicle). Can one of ou point me in the most logical place the antenna mount should be located)?

Thank you.
Posted via Mobile Device
 

·
Registered
Joined
·
1,866 Posts
I do believe its under the front roof air dam. On my 12 i never had issues with the XM. But i have read some have had bad reception etc....
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I do believe its under the front roof air dam. On my 12 i never had issues with the XM. But i have read some have had bad reception etc....
Thanks for the reply. That makes sense. Went out to the X to see which tool I need to remove it. I don't have the right one but can see where the screws have been recently removed and reinstalled. Very interesting to me since I just shipped the vehicle internationally. I'll let you know what I find when I get the right tool.
Posted via Mobile Device
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Thank you. I shipped the toolkit and other removable items separately. They are still a few weeks away...
Posted via Mobile Device
 

·
on line
Joined
·
2,047 Posts
you might consider upgrading to the terk marine round xm antenna.... you will have to drill under cabin light module.... i did it and painted the white round antenna matte black... good signal
 
1 - 7 of 7 Posts
Top