Second Generation Nissan Xterra Forums banner

1 - 20 of 25 Posts

·
on line
Joined
·
962 Posts
Discussion Starter #1
First off, yes, I can use the search button, yes, searched, and no, I didn't find an answer.


Ok, now that that's cleared up, here's my question:

I installed my AC shackles and TG spacers 3 weeks ago and have had no problems until yesterday. After some heavy wheeling, I began having horrible UCA contact in the right wheel. Why only in the right? What would suddenly cause contact of three weeks of them not hitting?
 

·
on line
Joined
·
2,077 Posts
when i spoke with greg at prg he mentioned there is some play in the connection b/t the LCA and the shock. it could be a little play caused the shock to slide up a little causing more chance of contact....double check the bolts and torque them to spec.
 

·
on line
Joined
·
15,651 Posts
I would check to make sure the bolts that mount the spacer to the spring bucket or the spacer to the shocks are still tight. If they came loose it could cause the LCA to drop further which would cause the UCA to hit the coil bucket.
 

·
on line
Joined
·
962 Posts
Discussion Starter #6
yup...I do believe I "grenaded" a coilover.

I checked it out and the spring looks a little weird. The rubber housing on the bottom is hanging off!

uh oh. So, what new front coilovers should i get?
 

·
Premium Member
Joined
·
9,791 Posts
mcampana said:
I do know there is some kind of plastic crap at the base of the springs. AND ONMINE ITS KINDA TWISTED, BUT IT CAME FROM THE FACTORY THAT WAY. sO YOUR ISSUE MAY BE NOTHING.
i have the same thing on my drviers side. the plastic is hanging off of the bottom. It doesn't look life threatening. It has been like that since day 1
 

·
on line
Joined
·
2,077 Posts
yeah dude, post up a pic so we can see, take the tire off and get some good shots. you can get stock replacement parts for a decent price

edit, new strut and spring on courtesy parts is around $150, so worst case senario, it's not too bad, but let's see some shots first
 

·
on line
Joined
·
628 Posts
If you did in fact blow, which I sure hope you didn't, I would get those stock ones for now so that you can spend the money on tires. After this weekend you proved that with some better tires you are in a very capable vehicle.
 

·
on line
Joined
·
14,014 Posts
USArmyX said:
If you did in fact blow, which I sure hope you didn't, I would get those stock ones for now so that you can spend the money on tires. After this weekend you proved that with some better tires you are in a very capable vehicle.
LOL, yeah! Hopefully next time w/ new tires we can let the tow straps get some rest!
 

·
on line
Joined
·
962 Posts
Discussion Starter #16
well, this morning when I got outside to take my tire off, this squirrel started shreiking at me with a "nyak nyak" sound...I had to take a picture before it ran away....but no! It got closer to me shrieking that sound.

it was priceless!


anyhoo, here are the pictures. You can see that when it was lifted onto a jack and the tire came off, there was severe contact on the UCA and coilbucket. Could the problem be a bad ball joint?







and then the tire goes on and...

 

·
on line
Joined
·
15,651 Posts
The only reason the UCA would rest on the coil bucket when the vehicle is jacked up is if the shock (with spacers) was too long). With our front ends, the shock acts as the downward travel bump stop.

The only things I can think of is that you bent something with all the jumping or the spacers are too long.
 

·
on line
Joined
·
962 Posts
Discussion Starter #20
yeah, the bending of something is my bet. But, why one tire? Why do some people have it, and others don't who haven't jumped their X? I don't understand! It is the most annoying sound I have ever heard!
 
1 - 20 of 25 Posts
Top