Second Generation Nissan Xterra Forums banner

101 - 109 of 109 Posts

·
NewX’er 4life
Joined
·
2,538 Posts
Use the hardware I specified in my post:

https://www.thenewx.org/forum/14-su...3-radflo-clunk-how-i-fixed-9.html#post3495513

Link to bolts specifically: https://www.boltdepot.com/Product-Details.aspx?product=15194

I don't think you get a better fit in the Radflo sleeve than you do with these bolts. I had no problems with 155ft/lbs of torque.

They no longer have 80mm lengths, will 75mm be long enough? Can you get a measurement or a pic? I'd appreciate that...just trying to do a bit of preemptive maintenance before my trip out West next year.
 

·
TNX Veteran
Joined
·
4,240 Posts
They no longer have 80mm lengths, will 75mm be long enough? Can you get a measurement or a pic? I'd appreciate that...just trying to do a bit of preemptive maintenance before my trip out West next year.
Yeah, 75mm should be plenty. I remember the 80 being a little long anyway.



BTW, west as in Washington? ;)
 

·
NewX’er 4life
Joined
·
2,538 Posts
Yeah, 75mm should be plenty. I remember the 80 being a little long anyway.



BTW, west as in Washington? ;)
At some point yes. Plan on hitting BC and heading down to the US afterwards and work our way to MOAB or something, criss crossing between mountains and the coast depending on what we want to do. We are going to start planning after the wedding in September.
 

·
Registered
Joined
·
192 Posts
Discussion Starter #104
After ~3 years of being clunk free I started getting similar noise on the drivers side again whenever there was sharp uptravel. Did some trouble shooting and I found quite a bit of play in my inner and outer tie rods on both sides, drivers side lca ball joint, both SPC ball joints on the UCAs and. After replacing all of those the clunk was still there and I pinpointed it to my drivers side Radflo.

I was all set to pull the Rads and send them back for service but on a whim I put a few drops of triflo lube on the spring perch and surprisingly the clunk disappeared again. Maybe something else for people to try if they're getting clunks?
 

·
Premium Member
Joined
·
268 Posts
Use the hardware I specified in my post:

The Radflo Clunk - How I Fixed It - PBR

Link to bolts specifically: Metric hex bolts, Zinc plated class 10.9 steel, 14mm x 1.5mm x 80mm - Bolt Depot

I don't think you get a better fit in the Radflo sleeve than you do with these bolts. I had no problems with 155ft/lbs of torque.

Sorry to revive an old thread....but where are you guys getting the 155 ft/lbs from for torque specs? FSM has the torque specs at 98 ft/lbs for the lower shock mount. Just curious, as I'm piecing my Titan Swap and want to make sure I get these bolts before I start wrenching.
 

·
Registered
Joined
·
1,641 Posts
Sorry to revive an old thread....but where are you guys getting the 155 ft/lbs from for torque specs? FSM has the torque specs at 98 ft/lbs for the lower shock mount. Just curious, as I'm piecing my Titan Swap and want to make sure I get these bolts before I start wrenching.
I don't know why, but the FSM for different years changed this spec. It says 155 ft lbs for my '09 but at some point changed to 98 ft lbs. See here:

The OG thread with all the torque specs is here:
 

·
TNX Veteran
Joined
·
4,240 Posts
Sorry to revive an old thread....but where are you guys getting the 155 ft/lbs from for torque specs? FSM has the torque specs at 98 ft/lbs for the lower shock mount. Just curious, as I'm piecing my Titan Swap and want to make sure I get these bolts before I start wrenching.
yep ^^ same as @outback97

I've been doing 155 ft/lbs since I've owned my X (nearly 5 years) and I've probably tightened the lower shock down ~20 times. That lower mount hasn't failed me yet...
 

·
Premium Member
Joined
·
268 Posts
yep ^^ same as @outback97

I've been doing 155 ft/lbs since I've owned my X (nearly 5 years) and I've probably tightened the lower shock down ~20 times. That lower mount hasn't failed me yet...
Ok, thanks guys! I’ve got a ‘15 so I’ll likely just follow the FSM I’ve got for it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
234 Posts
Changed out my bolts more than a few years ago. I totally forgot about the noise......Until seeing this thread again. I lubed my bolts with Lucas Red Anti Seize Grease.
 
101 - 109 of 109 Posts
Top