Second Generation Nissan Xterra Forums banner

1 - 2 of 2 Posts

·
on line
Joined
·
631 Posts
Discussion Starter · #1 ·
well, today while driving around Las Vegas my X was running pretty hot. i noticed this when i tried to pass someone on the freeway and it wouldnt rev above 4000 rpm. i looked at the temp and it was near the H. i just moved back to Vegas from Ogden, Utah and i never had a problem while in Utah even while in Moab on the trails. but i pulled off the freeway, popped the hood and coolant was spitting out the overflow tank. i waited about 45 min for it to cool down to 1/4 and checked the coolant level. i added about a little less than 1/2 a gallon of 50-50 mixed antifreeze and water to both the radiator and overflow.
this is the first time its happened to the X. yesterday i washed the radiator to get all the sand out from Moab, and washed the vehicle. i dont think i screwed anything up (the electric fan or clutch fan). both fans work, but i am seriously thinking of ditching the clutch fan in favor of a electric fan, so i have two electric fans. i dont think the las vegas heat has anything to do with this, but this week i will take it in to the dealer to see what they can find. the thermostat isnt stuck, both hoses are hot and pressured. no visible leaks anywhere.
i do have 2 lights mounted in my grille, but i dont think they could be suspect. ill remove them today and drive it before i take it in. i know someone else on here posted something about running hot/overheating and i cant find his thread. i wanted to know if he found any problems with his. any suggestions?
 

·
on line
Joined
·
111 Posts
If you do move onto an electric fan, I would really like to know how everything goes as far as cooling efficiency.
 
1 - 2 of 2 Posts
Top