Second Generation Nissan Xterra Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
So I bought my Nissan back in 2020 may and it was the perfect xterra(2006).
Around January of 2021 the idle started messing up, I would be sitting at a stop light and the idle would slowly go down from 675 to 450 and the whole cabin shakes like hell. I have taken it into shops they said nothing is wrong or they don’t see what I am talking about. Cleaned the throttle body did nothing checked for vacuum leaks nothing had maf checked nothing. I am coming here as a last resort before I sell it. Anybody have a solution
 

·
Registered
Joined
·
52 Posts
Maybe Camshaft sensor is bad. Go oem sensor


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
436 Posts
I had that issue when I got my 2012. I cleaned everything up, changed the plugs and did the relearn procedures. That cured it.
 

·
Registered
Joined
·
170 Posts
Looking at all the conditions and timed steps needed for that idle relearn procedure to execute properly, it looks like something you'd have to repeat a few times before getting it right. The vehicle has to be fully warmed up, in park, turn off ac, lights, etc.. before even starting that procedure. I'd try the relearn again.

If that doesn't do it, then try replacing the PCV valve since you've already replaced the plugs/checked for leaks/cleaned the throttle body. The PCV valve is cheap to replace, but a pain to reach. Use a stubby adjustable wrench if you have one. Mine seemed to idle a bit smoother after replacing the PCV, which sounded just about done at 60k miles...shake/rattle test supposedly given an indication if the valve can still open/close.
 

·
on line
Joined
·
179 Posts
Plugged cats can cause rough idle due to back pressure from the exhaust. I'd imagine that could also lead to lower RPMs at idle too, although I have not heard of that symptom before.
 

·
Registered
Joined
·
342 Posts
This may sound crazy but I switched from an Optima Red Top battery to a new Interstate battery from Costco and my idle smoothed out some. Still doesn't idle real smooth but it did get better.
 

·
Registered
Joined
·
258 Posts
You said you replaced plugs and boots did you just replace the boots them selves or the actual coils? Cause weak coils can cause it too not making efficient spark
 
1 - 16 of 16 Posts
Top