Second Generation Nissan Xterra Forums banner

1 - 20 of 109 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter #1 (Edited)
I ordered a bumper from Black widow gear in January, I was speaking to them on Friday and they said it will be shipped early this coming week so I decided to start my review thread now.
I ordered the rear bumper with tire carrier, no paint and grade 8 hardware for $724.50CAD ($544usd) plus $75CAD ($56usd) Shipping for a total of $799.50CAD ($600usd)
Ordering the bumper online was straight forward, the website was easy to navigate. They have been easy to contact throughout the wait for my product, when I called march 31 it went to the answering machine so I decided to text them instead of leaving a message and they responded to me in 3 hours, that was the longest I had to wait to hear back from them. One thing I would have liked to seen from them (this seems to be a problem with pretty much all companies building and selling aftermarket parts) is more communication with the client about delays. 6 weeks after I ordered would have been March 11 and when I spoke to them a few days before that they still didn't have any idea when it would be ready. I waited until 9 weeks before I asked for another update but it would have been nice to get even an email from them telling me what my order status was after we passed the 6 week mark. It's not really a big deal but it's something I'm sure everyone ordering a product would appreciate...... 10 weeks ins't that long to wait for a bumper just better communication would be nice.

Jan 28th I ordered the bumper after getting in contact with them and confirming that there was a 6 week lead time on orders after reading on the website that the lead time was only 6 weeks.

March 7 I texted them to check the status of my order and at that point they couldn't give me even an estimate on when it would be built or shipped.

March 31 I decided to get in contact again and they told me that it was on the table being fabbed and that it would be shipped out the first week of April.

April 12 Today I received a shipping confirmation email from Black Widow, they said it should arrive friday if Fed-ex delivers on good Friday. Apparently the delay from mar 31 until now was due to it being painted, I didn't want it painted. I'll be watching my email for a tracking number today or tomorrow.

April 14 I checked my fedex account looking for a notification that a shipment has been processed and so far nothing. I called blackwidow and got the answering machine again, I told them I will be filing a paypal dispute and they called me back within minutes. I'm getting tired of the run-around I've been getting from them over the last few weeks, now the story is that they hire a 3rd party courier to take their products to fedex to have it shipped. Apparently they are 3 hours away from the nearest fedex depot....... I was told they'll call me first thing Monday morning after they call this courier to find out what is going on. She said that it should have been shipped already and I asked for a tracking number which conveniently she doesn't have because of this 3rd party who ships for them but on Monday april 10 she told me that she would provide me with a tracking number by wednesday april 12 at 4pm. I'm not sure at this point if I should just start a paypal dispute or wait until Monday morning.

April 20 The bumper was delivered today. I'll be home mid may for a few days and I'll try to get it installed while I'm home.

May 13 I got home today and tried to install the bumper and it doesn't come close to fitting. The measurement from inside the frame rails where it mounts is 41" and the tabs that are supposed to mount there are 41 9/16" . It looks like they welded on the mounting bracket using the 41" measurement but they made it inside to inside instead of outside to outside of the tabs. I'll be calling them and trying to get it figured out on Monday.

June 30 I'm still waiting to get my bumper back from black widow. I sent the bumper back to them to be fixed and I told them that I was going on vacation June 9 and would really like to get the bumper back before I left so they assured me that they would fix it immediately and ship it back to me. According the the tracking number they received the bumper may 23. I had a text from them on June 5 asking when I was leaving for vacation and I told them again that it was June 9. I didn't even bother asking what was going on at that point because honestly I've given up any hope that they will stay true to their word, I planned on dealing with it when I got back. So on June 16 I messaged them again asking what was happening with my bumper and they told me that they didn't want to ship it while I was away in case I wasn't here to receive it. I guess the promise that they would fix it as soon as they got the bumper went out the window as soon as I shipped it! So they said that they would ship it out in the next shipment so
I would have it before long. June 22 I asked them again about it and they said the next shipment was leaving the next day and that I would get a tracking number a day or two after it was shipped. I've been more than patient with them and obviously harassing them doesn't seem to do much so I waited until today to ask them AGAIN where my bumper was. They said that I should have gotten the bumper days ago but unfortunately for me everything is packed up because they are moving locations and she doesn't have a tracking number right now. I guess I have to wait until "tomorrow morning at the latest" to get a tracking number because they have it boxed up somewhere but the for some reason didn't give me the number like they said they would after it shipped. I don't even know what to say about these guys at this point....... I'm giving them 24 hours to get me a tracking number to prove it was shipped and if not I'll be filing a paypal dispute and demanding my money back! These guys are the worst company I've ever dealt with, the need to be added to vendors purgatory so no one else has to deal with this ****!

Literally 5 minutes after posting this it showed up at my door! I'm going to try to install it right now

I just finished working on the bumper for the last few hours and I've given up on it. This bumper doesn't come close to fitting in any way! To start I had to slot the 4 bolt holes in the bumper in order to make it fit somewhat close to the xterra. I had a huge gap all around the bumper and it didn't mount on the rear level, one side of the bumper stuck out around 1" from the plastic corner piece the other side had a smaller gap. After finally removing enough material to get the bumper to mount so that it was at least half decent I attached the tire carrier. It fit to the bumper great but the tire doesn't mount to the carrier unless it's flipped around so that the tire is sticking out from the rear of the xterra way too much. It doesn't look anything like any other tire carrier I've seen and definitely not like the pictures they have on their website. The hi-lift jack mount has a bolt that was welded to it so that you can just slip your jack on and then in theory it is supposed to bolt to the tire carrier. When the jack is on the welded on bolt it doesn't come close to lining up with the upper mounting point and there is no way to push it over enough to make it work. Another issues is that the license plate mount is in a place where you have to half open the tire carrier, guide the door past the license plate and then finish opening the tire carrier so that you don't hit the rear hatch on it. If you open the tire carrier fully and then try to open the rear hatch it hits the license plate mount. It would be a complete pain in the ass to open the rear hatch with a set up like this.

I got the jack to mount. I didn't notice that there were 3 holes in the base of the jack, I only saw the 2 holes on either side. Once i realized that there was a 3rd hole it worked, it's out of level and twisted on the base but it's on now.


They are telling me that I need to buy a wheel spacer in order to mount my tire because I'm running 285s and those aren't oem. I'm trying to track down someone with an OEM size spare so I can mount it on the tire carrier and send them pics. There is at least a 1" gap all around the wheel hub when I square the tire up with the rear of the xterra so I'm sure it's not the little bit of extra width.

 

Attachments

·
Registered
Joined
·
167 Posts
Discussion Starter #2 (Edited)
So here is the bumper. It looks well built other than the issue with the tabs not lining up. I just sent some pictures to black widow and they got back to me within minutes, they will be picking it up on monday or tuesday to take it back to repair it. They said they sent out 3 that had the wrong dimensions.
 

Attachments

·
Registered
Joined
·
167 Posts
Discussion Starter #4
it sucks, but yah delays happen..
I'm not upset about it at all, I completely understand that sometimes **** happens. I only mentioned it because of the lack of communication on their part about the delay, just something that hopefully they can improve in the future.
 

·
Registered
Joined
·
521 Posts
Interested to see and hear how you like the bumper. Do you know what type of clasp is used to hold the swingarm closed?
 

·
TNX Veteran
Joined
·
3,625 Posts

·
Registered
Joined
·
181 Posts
I wish you the best of luck. I ordered sliders and full skid plates from them with a buddy of mine that ordered the same thing, at the same time, on the same credit card. Lead time they gave us turned out to be twice as long for the first set which they shipped separately and second set we had to argue about giving the right address, that one took forever to come in...... To add to the pain half the holes on the skid plates don't match and one plate looked like it had been cut by hand with a grinder...
 

·
Registered
Joined
·
181 Posts
When did this happen? All the pieces are CnC cut now so I am curious. So the lead time was a bit delayed on yours, but the second was within the estimate? Even if you ordered at the same time it was two separate orders to two separate addresses right?

Who messed up the shipping? Did they not ship it where you told them?
It was early 2016
Lead time was doubled on first set
Lead time was something like tripled on second set
Shipping was the same address done on one single order

When we asked them what happened with our second set they tried to blame it on us for giving the wrong address.....Well it's not hard to figure out we gave them the right address since we had received the first set already
 

·
Registered
Joined
·
181 Posts
As for the poor cut/fit and shipping issue I can't comment, I did see the CnC in person however. I also asked about skid plates and dropping my truck off to install them (in case holes were off) and he said it wouldn't be an issue. Guess we'll find out one way or another when I get them.
For sure, if I had the opportunity to go in person I wouldn't be so scared to buy from them again. As for lead time I didn't really care that much and to be honest everything is still sitting in my garage :| but the poor workmanship got me a bit pissed
 

·
Premium Member
Joined
·
1,910 Posts
I talked to him about the winch tray. When he contacted ZheKing he was basically told "don't worry about it, I figured things out". I was face to face with the guy and got absolutely no impression he was dodging anything and was anything else but honest. He showed me another tray in the shop that was ready to paint and be sent out. My shackles fit fine on it, all the lines measured fine with my frame bolts and it was the 22nd unit he made. All the pieces for either DIY or pre-welded units are cut on a CnC machine, and he said he never received a complaint except ZheKings's which I believe was a DIY kit.

I even asked about the fog light plugs and so on to be thorough because I wanted to know, no feedback about fitment issues from any customer about that either. Based on all that, could he have gotten a bad kit? Sure it's possible, but again the pieces are CnC cut to spec. It could also be DIY error. Not trying to be on any side here either, because as a potential customer I wanted to know all the facts of the matter as well.
None of that is correct. It was not a DIY kit either.
 

·
Premium Member
Joined
·
1,910 Posts
What was not correct? I remember you not being able to fit shackles and having to mess with L brackets (which is why I thought it was a DIY for some reason) and having a tight fit for the fog lights. Is there something else that was not mentioned?
Please see this thread to inquire about that review, it should answer all of your questions as well. http://www.thenewx.org/forum/70-product-reviews/230769-black-widow-winch-plate-bumper-2-5-stars-updated-03-28-17-10-30-am-cst.html
 

·
Premium Member
Joined
·
1,910 Posts
Not sure where you are going with linking me back to your winch tray thread. My only question was with you saying nothing I said was correct. What was not correct? Did you not have a shackle issue? Did you not have a fog light plug issue (very tight for the connector), did you not have a problem with the L brackets not lining up?
And I"m saying i'm not thread highjacking. All of those questions and more are answered in the other product review, as well as their response (What he told you was also not correct) when i was asking via text.
 

·
Premium Member
Joined
·
1,479 Posts
... I'm pretty much done trying to help people with this stuff, seems like one person always gets thrown under the bus when it comes to fabricators. I'll post my reviews when the time comes and people can do their little dance and I'll just leave it be.
From where I stand it looks more like running into the bus rather than getting thrown. You seem to know the guy personally, or at least have met and spoken enough to know he's married, and very often take on the role of protector. Nothing wrong with any of that either. It is what it is. I appreciate your input, but I'd be foolish to make it my only source for decision making. Don't get upset if I still want more input. (Johnny 5!)

I look forward to hearing from the OP here when the rear bumper does arrive.

For what it's worth, there's nothing magical about a CNC tool. They do what they are programmed to do and don't know if the program has a wrong number, if the operator is asleep, a monkey wrench falls in the gears, etc. Even with perfectly cut parts there's plenty of room for error when bending and welding. It may just be a hobby for me but I can appreciate how difficult it is.
 

·
Premium Member
Joined
·
1,910 Posts
To add to the pain half the holes on the skid plates don't match and one plate looked like it had been cut by hand with a grinder...
Your case seems to be the exception, not the rule, so the OP SHOULD have no problems with his bumper.

Regardless I'm pretty much done trying to help people with this stuff, seems like one person always gets thrown under the bus when it comes to fabricators. I'll post my reviews when the time comes and people can do their little dance and I'll just leave it be.
Based on the 2 posts I've only ever seen about this fabricator on this site ( one being an in depth product review, the other being a comment), both discussing frame holes not lining up, I wouldn't say it's about any "cases in exception", but at this point the standard. I look forward to this bumper review, to see what the deal is. As you said your self, they are new to the X, maybe there is a curve that needs to be overcome, so far as we've gathered, there is.

Also, these aren't "people asking for questions needing help"... they're product reviews, posting their experiences with said product(s). As I, and others, have said, if something is advertised as bolt on, it should be bolt on, it should be the product on their web-site and in the pictures. I certainly don't mind slight modification, I just prefer to know what i'm getting in to, especially when i have 4 cars all set up for decisively different things i have to devote time to.

I look forward to hearing from the OP here when the rear bumper does arrive..
As do I, which is why I would prefer there be a thread set up about this vendor, IF NEEDED, I'm all about the community (no matter what it be, whether Z's, X's, or TDI's or whatever). If I could, I'd drop my non bent frame X off to let them see what matches up and help their fab work, since I drive my X about once a month at this point and it wouldn't make a difference to me, unfortunately, they aren't close enough for me to do that. At this point, I will no longer comment on this thread. if anyone has any questions about my experience with them or the product i received, they can see the product review i made and comment on that or certainly send me a PM.
 

·
Premium Member
Joined
·
1,479 Posts
Such is life, I found this only because I wasn't looking for it...
http://www.thenewx.org/forum/23-exterior/202841-rock-sliders-install-3.html#post3251346
(Was trying to learn about Shrock sliders to see if I could convince my better half to let me get in on that group buy)

Anyway, after reading what this guy said almost a year ago I am both more eager to hear OP's review and less expecting it to be good news. :dontknow:

His words, "I took the pre-built", and "I have yet to install them as the holes didn't line up". (He did get them installed later in the thread at a local shop.)

@tfxluc, I'm not clear on one part. Did you order 2 sets shipped to the same address and they had a problem somehow?
EDIT: nevermind, I'm an idiot and confused myself. Found it, it's clear now. I blame the tiny screen...
 

·
Registered
Joined
·
167 Posts
Discussion Starter #19 (Edited)
It's been a week since they told me it was on the fab table being built and I still haven't gotten a confirmation that it's been shipped. Tomorrow I'll call them back and see what is going on, I'm just not sure how it would take them this long to weld up a rear bumper that they supposedly started working on Friday. It's not even being painted so that can't be the delay this time.
They said it would be shipped early this week, they said that I would get an email from both them and the shipping company with a tracking number.
 

Attachments

·
Registered
Joined
·
308 Posts
It's been a week since they told me it was on the fab table being built and I still haven't gotten a confirmation that it's been shipped. Tomorrow I'll call them back and see what is going on, I'm just not sure how it would take them this long to weld up a rear bumper that they supposedly started working on Friday. It's not even being painted so that can't be the delay this time.
They said it would be shipped early this week, they said that I would get an email from both them and the shipping company with a tracking number.
I cant believe how anxious I'm getting for someone else to get their bumper in!! How much did they quote you for shipping (If you don't mind my asking)? I asked for a quote on shipping to the U.S. and was told 90CAD which seams really low considering most companies in the U.S. charge over 100USD to ship similar bumpers.
 
1 - 20 of 109 Posts
Top