Second Generation Nissan Xterra Forums banner

1 - 17 of 17 Posts

·
on line
Joined
·
2,938 Posts
Discussion Starter #1
AC now sells them


 

·
on line
Joined
·
163 Posts
I've had mine for a while and just havne't had the time to get underneath the car to take photos and do a write up. THey've had them for sale since September.
 

·
on line
Joined
·
1,479 Posts
Dumb question. but do the sway bar move up and down since is not connected to the chassis? or does it stay horizontal?
 

·
on line
Joined
·
251 Posts
I have both front and rear gone, do they sell both disconects?
I don't fell like I need them (drives fine even during quick lane changes) but just incase they say I need them for inspection I won't have to keep puting them on and off.
 

·
on line
Joined
·
15,651 Posts
I don't think we'll ever have front disconnects as there is no where to move the front bar to get it out of the way.
 

·
on line
Joined
·
1,695 Posts
Where does the rear swaybar mount once it is disco'd? I would hate to think it is just flopping around back there. I just pulled mine off entirely... did the same with my old Ranger and never knew the difference. I'm really not worried about it with as stiff as the rear springs and Bilsteins are.
 

·
on line
Joined
·
2,540 Posts
RockyMtnX said:
Where does the rear swaybar mount once it is disco'd? I would hate to think it is just flopping around back there. I just pulled mine off entirely... did the same with my old Ranger and never knew the difference. I'm really not worried about it with as stiff as the rear springs and Bilsteins are.
I know on the past models, people just zip tied them up to the axle so they didn't hang down.
 

·
Read Only
Joined
·
656 Posts
usmc xterra said:
Well that is nice, I sure like to see people use em. I'm totally against removing the rear sway bar from experience. Too bad I am not allowed to buy them! Shucks! MC
Some one else could buy them from AC, then resell them to you, MC. That way you could still keep your integrity intact. You would never have to admit that you had done business w/ AC.
 

·
on line
Joined
·
163 Posts
Re: rear swaybar disconnect photos

dnorton said:
Spicoli,

Treat us all to some photos, please! :bounce:
Well it is too snowy and I don't have a garage... once the weather gets nice enough to play outside on the ground I'll get some pics up, etc.
 

·
on line
Joined
·
463 Posts
This may seem a bit out of line But, ,,, I don't believe the picture is for the 2005 rear sway-bar quick disconnects.

Mine are straight. As were the stock ones.

Or did 4x4 parts send me the wrong ones?
Please advise, I have a follow-up question as well,,,
They seem to make some noise in the rear when body rolls side to side ?

Regards, Jim B
 

·
on line
Joined
·
163 Posts
They are straight... as far as noise I don't hear anything extra... but I've always got my radio playing.

They have a bit of play in the attachments (but nothing big, very small amount)
 

·
on line
Joined
·
463 Posts
Thanks, I thought they were the correct ones.
As for the noise,,,,,,,,Hmmmm? I'll keep snooping about.
Later,
Jim B
 

·
on line
Joined
·
47 Posts
old thread, sorry just checking to see if anyone has any photos of the disconnects and any further thoughts? Is this working out ok?
 

·
Registered
Joined
·
2 Posts
QD

I installed the quick disconnects on my 08 Xterra and it makes a lot of noise when the body rolls. Is anyone else having this problem? I purchased mine from 4x4parts.com
 
1 - 17 of 17 Posts
Top