Second Generation Nissan Xterra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1 (Edited)
My question is basically...….WAS or IS there some kind of pad in-between the leaf's other then the outside Insulators..... When I pull out of my drive way and cut the will so Basically making the rear leaf's articulate, I get the awful creaking noise like I have a Broken Leaf, or something rubbing against something like metal on metal, I Checked both leaf packs neither have a cracked Leaf that I can See...

  • I have Changed all the bushings I have OME leaf bushings wrapped in Teflon lubed with Energy Suspension Grease.
  • Changed all leaf pack Insulators
  • added a 1/8" graphite Padding in-between the add a leaf and leaf pack so they don't rub metal on metal
  • Power washed & added Silicon spray to the whole leaf pack
  • Pressed the tabs holding the leaf's together tight
  • Tightened the U-bolts To Torq Spec.....
Maybe it could be my 2 degree shims I'm lost in this god awful noise if i back out straight I have no noise.... But I can also drive over a curb I must get the front and rear tire on the curb so I'm putting pressure on the rear one i do that i can get it to make the creak noise ill try and video it if I can...


I have 2" Shackles with 1" add a leaf's
2 Degree shims
285's on pro-comps
Shocks are a year old
Moog stab links & bushings just changed 6months ago
&
OME Front & Rear Leaf Pack Bushings
leaf's are the originals

Any helps or ideas would would help me greatly thanks!
 

·
Registered
Joined
·
477 Posts
I have this same issue with my Alcans and it comes and goes.
 

·
Registered
Joined
·
206 Posts
I had the same issue. I greased the crap out of my shackle bushings (both ends) last March and it went away. The creak is starting to creep back in though. Easy enough to re-grease periodically though.
 

·
Registered
Joined
·
1,850 Posts
My first priority would be determining exactly where the noise is coming from.

Have someone else do the driving while you investigate .
 

·
Registered
Joined
·
26 Posts
Had a creak on my frontier I thought was the passenger side shackle. Ended up being the rubber exhaust hanger right near the shackle. Just because the suspension is moving doesn't mean it's causing the noise and/or something else isn't moving also. It took be about a week to figure out it was the exhaust.
 
1 - 6 of 6 Posts
Top