Second Generation Nissan Xterra Forums banner

61 - 79 of 79 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #61
I didn't have the torque converter properly seated into that cog. When I torqued down the transmission I forced it into the cog. Crack. Stupid mistake. I just assumed the trans was needing to pull in more. Seems this was in the way.

Wow! How does something like that happen? (Sorry for the dumb question. I know nothing about the inner workings of automagic transmissions)


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
51 Posts
Discussion Starter #64
So, progress this morning.

New sprocket, all cleaned:


New housing and new seal for the torque converter:


Sprocket in. Lubed up with fresh trans fluid:


Cleaned up the rest of the housing. The bolts that hold it into the transmission are sealed with grey RTV. I cleaned it all up really well:


Fresh fluid in there, too:


Assembled and torqued all the allen-head bolts to 80 INCH-lbs.


I'm currently waiting for USPS to bring the big o-ring to set it into the trans. Updates this afternoon, I hope.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #65
O-ring came in this afternoon. Installed it and slid the assembly into the transmission.


Cleaned up all the bolts. I stuck them in a drill and used a scotchbrite pad to clean them up. Then put new RTV on them and installed to 35 ftlbs.


Bell housing bolted right up, but I forgot a pic. Plan was to just get it into the car, but I got carried away. Nothing went smoothly, but this is the result.





Have some things I still need to address. I haven't changed the front diff fluid, yet. My crush gaskets on the exhaust didn't like being used 3 times. I'll pick up another set or two of those to replace. I have a ridiculous squeak from the front driver's wheel. I'm assuming it's the bearing. I have a new pair of fronts that I bought. Hope this will take care of the noise AND the ABS lights.

Transmission feels good. I'll keep an eye on the fluid and do some short drives around town. Hope to have some fun updates this year!
 

·
Registered
Joined
·
121 Posts
I didn't have the torque converter properly seated into that cog. When I torqued down the transmission I forced it into the cog. Crack. Stupid mistake. I just assumed the trans was needing to pull in more. Seems this was in the way.
You are the first person ever to do that! Don't ask me how I broke a camshaft.....🤷‍♂️

Thanks for the posts!
 

·
Registered
Joined
·
51 Posts
Discussion Starter #67
Got about 50 miles on the truck today. CEL has popped back up for cats and evap valve. I’ll attempt to clean the charcoal canister in a couple weeks when I get some time. I changed the front diff fluid today and greased my new u joint. Popped her into 4 high and low. Success!

Next on the list is front wheel bearings. I can hear the drivers side. Need to get the abs lights off. After that I’ll worry with the cat situation.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #69
Thanks! Not much new. I've put about 350 miles on her. Still running pretty well. Replaced the washer fluid reservoir tonight and installed the fender liners. Going to try to clean out the evap canister this weekend to get rid of that code.

Upper control arms, lower ball joints, and front hubs hopefully going on soon. Maybe some 5100s if I can set a few bucks aside.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #70 (Edited)
Worked on the X today. Got a few things done, but not happy with the results.

Now that she's driving, I've been wanting to get all the lights off of the dash. I've had the ABS, SLIP, and VDC lights on. I assumed I had a bad wheel bearing up front as I've had some noise. Replaced them this morning along with the upper control arms. Pretty easy job. Everything came apart like it should.

I was super hopeful that the lights would go off after a little driving. Unfortunately I still have yellow all over the dash. Bummer. I bought a little scanner that will pull ABS codes. Looks like 1110, 1160, 1163. The truck needs aligned, and the steering is a little off center. I will probably get that done before I go trying to fix any of that. I'm reading that you need Consult II to talk to the truck and calibrate sensors. Can anyone attest to that?

I also pulled my evap canister out and blew it out. It actually didn't blow out as much as I thought. Hopefully I did some good. Trying to clear up my P1446 code. If that doesn't do it I'll pick up a solenoid this week. Also removed the rear mud flaps while I was there.

Swapped out my steering wheel controls. I bought a brand new steering wheel over the past few months. It was a newer version and had updated controls. Nothing really worked right. Put the old ones in from my old wheel. Functions perfectly.


Have a few things in the garage and on the way.

SuperPro steering rack bushings
Lower control arm ball joints
DT midpipes (which will get high flow cats welded in)
Bilstein 5100s

If anyone can chime in on my ABS woes, I'd appreciate it. I become obsessive with things like that.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #71
Spent a couple hours under the truck last night. Replaced the big u joint on the main driveshaft and the second one at the front diff. They were trash. A lot quieter and my vibration is gone on the highway.

I still have one noise that’s bugging me. It’s almost a ringing. I’m wondering if it’s the timing chain. Decently loud. It’s at idle, only when I rev it just right or am driving. Timing is on the agenda, so I guess we will see soon.

DT mid pipes showed up last night and 5100s deliver today.
 

·
on line
Joined
·
117 Posts
People usually describe the timing chain sound as almost like a supercharger. Not necessarily the high pitched whine per se, but just the general loudness and kinda forced air sound. When I had mine fixed, it had gradually gotten so loud that I was shocked at how quiet the engine was afterwards. And when I took it to the dealer they were familiar enough with this issue that it just took hearing one startup for the service rep to know that was the problem.

All that being said, your year model is right in the affected range so it's a good thing you'll be getting it checked soon.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #74
Fixed it. Got home last night and isolated the problem. I thought it was the secondary cats rattling. Pulled them off before work this morning.m and found the issue. Oops. I ordered a set of o2 spacers with a small piece of catalyst in them to fool the emissions. They have a small cap on them that screws on. Cap must have vibrated off.
Long story short, DY mid pipes are on, truck is louder, no rattle.

Shocks came in!

127467
 

·
Registered
Joined
·
26 Posts
Hey man. Cool build thread and thanks for the consistent and informative updates. I didn't quite catch the reason why you got new headers though. Could you please explain?
 

·
Registered
Joined
·
51 Posts
Discussion Starter #76
When I bought the car it had all the emissions codes. With 188k on it, there was a good chance the cats were bad. I just figured I'd simplify the engine bay and make a little more power. Hope to be getting some high flow cats on it within a couple weeks. It's pretty dang loud right now :)

I have to get a friend's car out of my driveway today and I'll be working on lower control arms and the 5100s. Then off to the alignment shop.

Hey man. Cool build thread and thanks for the consistent and informative updates. I didn't quite catch the reason why you got new headers though. Could you please explain?
 

·
Registered
Joined
·
51 Posts
Discussion Starter #77
Quick update. X is on jack stands. With the help of my sawzall and a Diablo blade, the driver's side LCA is off. Strut is off. Fedex is 2 days late with my ADO lift and new bolts. I'm in a holding pattern.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #79
I have 5100s in my garage waiting to install. I was going to do the lift later but decided to do it all at once.

Got their RCKilla kit to go with them.

Sweet! I mean, not sweet that it’s late, but are you getting their med springs and 5100s?
 
61 - 79 of 79 Posts
Top