Second Generation Nissan Xterra Forums banner

1 - 12 of 12 Posts

·
on line
Joined
·
278 Posts
Discussion Starter #1
Anyone else have a problem with the plastic panel on the inside of the hatch squeaking? I know that the prongs are not snapping into the holes on the inside of it. So, the squeaking is coming from the fact that the panel is not entirely secure, and parts of it are rubbing, causing the cricket-sounding squeak. How do I cure this? I have pounded the heck out of the panel, trying to snap the prongs into place, but they just pop right out. Any thoughts?
 

·
on line
Joined
·
278 Posts
Discussion Starter #3
Never. I DID buy it used, so perhaps the guy before me did. I pulled the top portion of it back, trying to assess the problem. But, that's it.
 

·
on line
Joined
·
1,864 Posts
:clown: Well, off the top, I don't know about the '05, but I seem to remember a couple of tabs ON TOP mine, to secure the Hatch panel, could be wrong, but--

--There are two (2) 10 mm bolts that hold the bottom, inside handle and panel tight against the HATCH and two (2) 5mm (??) bolts BEHIND the medical kit, that add more strength to the stupid plastic press snaps inside the panel--

--Check out those four (4) bolts, for tightness and that might doit--

-- :geek: :geek: --JIMBO
 

·
on line
Joined
·
127 Posts
DUDE same problem and it's driving me crazy! Roads out here aren't the smoothest asphalt (makes road biking a pain... literally) But that back trim piece is my nemesis. I never took it off, just started one day...
 

·
on line
Joined
·
1,667 Posts
i have never removed my rear panel but, i did add extra weight to the door hatch. i added lights where the first aid kit belongs. i believe that the weight from my lights plus slamming the hatch shut will pop those pins out. im currently buying a new bag of replacement pins as we speak. thanks for the reminder.
 

·
on line
Joined
·
264 Posts
mine does it too and the dealer took mine off and reinstalled it. so im gunna have them fix or replace it
 

·
on line
Joined
·
3,050 Posts
me to lately...I removed the rear hatch panel just to do the 3rd brake light mod, but I have added weight on the passanger side of the hatch (gobi ladder) since that install my hatch has been squueky...more so when its colder outside
 

·
on line
Joined
·
527 Posts
I HAD that same problem...

I purchased my X used and heard it... had a friend crawl back while it was making the noise and he figured out it was the window... WRONG!!!

Remove the plastic and look where the prongs/tabs go in and notice they are bent or deformed... fit it and then reinstall and :cheers: ALL FIXED!!!
 

·
on line
Joined
·
278 Posts
Discussion Starter #10
roadkill, did you just rebend the tabs to make them fit? I was thinking about some kind of putty to adhere the prongs to the holes. The only problem would be that it might be a permanent thing, where I can't get that back panel off anymore. I might take it completely off this weekend and see what I can find. Kind of nice to see that I am not the only one with this problem.
 
1 - 12 of 12 Posts
Top