Second Generation Nissan Xterra Forums banner

1 - 4 of 4 Posts

·
on line
Joined
·
2,876 Posts
Discussion Starter #1
my 07 s model 4x4 is pinging/knocking (sounds like a marble in a jar) alittle. It seems to ping right after the transmission shifts into the next higher gear and under light load. It seems to not do it though like in the morning when the outside temp is cool. I tried higher octane gas, but same thing. I have 10,000 miles on it and have changed the oil religiously at 3500 miles......


is this "normal" or should i be concerned? You can only hear it with the windows down and with very light acceleration. heavy acceleration does not cause pinging/knocking...

thanks...
 

·
on line
Joined
·
612 Posts
I may be wrong but I think this was addressed in another thread. I think it's common and most have experienced it. Not quite too sure why though.
 

·
on line
Joined
·
21 Posts
The reason it probably doesn't do it when it is cold out is because the ECU is putting in more fuel due to the lower temp which helps prevent the pinging.

It might be worth putting it on a dyno and run it similar to the way it is in the street while logging the air fuel ratio and see if it is leaning out for some reason at that point.

Any performance modification?
 

·
on line
Joined
·
2,876 Posts
Discussion Starter #4
only performance mod are my NC beach buggy license plate and my OBX stickers... Adds like 10hp supposedly.. ;-)


nope, bone stock......


it seems the hotter/humider it gets, it does it worse.... i suppose no biggie. you said there was another thread?


thanks...
 
1 - 4 of 4 Posts
Top