Second Generation Nissan Xterra Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2008 SE 4x4 115K

Ok, I have seen a lot of threads about P0463 and the notorious FSU so I have Rock Auto sending me a nice new $195 DENSO Fuel Pump and Housing Assembly... However, the cause of the failure occurs whenever I fill up the tank and it doesn't shut off until the neck is full - thus overfilling the tank and causing the code (tried different pumps and flow speeds)… Is there some other reason, sensor or vent issue with the EVAP system that would constantly cause the gas pump to not shut off automatically? Just don't want to replace the pump assembly to have the same issue again or worse yet, destroy my EVAP canister.

Day before yesterday she threw a P0304 in addition to P0463 which I then cleared and swapped coil packs with cylinder 2... the misfire hasn't come back but the high fuel level P0463 did even though I'm running at about 1/2 tank. Could the codes be related in any way? (I have a Hitachi coil on order just in case)

Xterra.jpg

Thanks.
 

·
Registered
Joined
·
102 Posts
years ago, I was a Fuel Technician and repaired fuel dispensers when there were issues. There are two types of fueling points, a vacuum system and a balance system, a nozzle will click off when the mini hole near the end of the metal spout senses either no more vacuum pressure, or in a balance system an increase of back pressure. So I would think that the nozzles are in bad shape and by having a bad diaphram or bad venturi tube.
 
  • Like
Reactions: Renegade
1 - 2 of 2 Posts
Top