Second Generation Nissan Xterra Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
3,797 Posts
Discussion Starter #1 (Edited)
Had the SES light on this morning when I started the X. I scanned the code and it came up P0456, small EVAP leak.

I didn't see a thread here dedicated to this code, but poking around in various threads points to a gas cap problem. I'm hoping that's right, I already know where the gas cap is and how to get it off. I did have a Loose Gas Cap come up on the odometer display about a month ago.

I cleared the code this morning, light didn't come back on for the commute, but it's still stored. My first try on keeping the code from coming back is applying a very small amount of grease on the filler neck where the gas cap rubber seal seats.

We shall see...
 

·
TNX Veteran
Joined
·
541 Posts
Had the SES light on this morning when I started the X. I scanned the code and it came up P0456, small EVAP leak.



I didn't see a thread here dedicated to this code, but poking around in various threads points to a gas cap problem. I'm hoping that's right, I already know where the gas cap is and how to get it off. I did have a Loose Gas Cap come up on the odometer display about a month ago.



I cleared the code this morning, light didn't come back on for the commute, but it's still stored. My first try on keeping the code from coming back is applying a very small amount of grease on the filler neck where the gas cap rubber seal seats.



We shall see...
Totes should make a how-to for those that may not be able to locate their gas cap.

Let's hope it goes away. Lol.
 

·
TNX Veteran
Joined
·
541 Posts
Oh jeez... I've heard stories about people driving on the freeway with the nozzles still in their fill tubes, dragging hoses. Lol. It's a scary world out there...

Or a wife texting her husband "hey, the 710 cap is off... Is that important?"
 

·
Registered
Joined
·
3,797 Posts
Discussion Starter #6
The SES light came back on, this time it was a P0442, so grease didn't help.

Next step was use a random gas cap I happened to find a while ago. That didn't help, a P0456 came back again this morning.

I'll be buying a cap on general principle, but I'm expecting I'll be digging deeper after putting a new gas cap on.
 

·
Premium Member
Joined
·
1,474 Posts
For what it's worth, my evap related codes haven't come back in 4 years after the following steps:
  1. Replaced gas cap
  2. Replaced clogged vent solenoid (on the can)
  3. Replaced ok-looking ? solenoid (on the engine intake)
I did not have to change out the pressure sensor or any tubing and the charcoal in my can was fine. Sorry I can't remember the exact name of the front solenoid, it's in the FSM though and wasn't very expensive if I recall.
 

·
Registered
Joined
·
3,797 Posts
Discussion Starter #9
Thanks for the leads guys. 29er's #2 is where I figured I'd be headed next week. I ordered a cap with the local stealership, comes in tomorrow.

Semi-pro tip, if you get the part up on an online source you can haggle price with the parts department. They wanted $35 for the cap, I said I'm looking at it online for $23.08 and they agreed to match the price. Other times they've not matched the price but lowered their asking price. Works great if shipping cost or time waiting for parts is a deal breaker for an online purchase.
 

·
Registered
Joined
·
3,797 Posts
Discussion Starter #12 (Edited)
There were two possible caps from Nissan. I was surprised when I looked on the X's cap and saw the part number, at least I know I got the right one. Now to see if the SAS comes back.

 

·
Registered
Joined
·
3,797 Posts
Discussion Starter #13 (Edited)
About 150 miles into the new cap I got the Loose Gas Cap on the odo and a pending P0442 after I got home. Looks like I'll be digging into that solenoid.
 

·
Registered
Joined
·
3,797 Posts
Discussion Starter #14
Been almost 2 weeks, no codes or messages have come back. I'm gonna let this one on the back burner for the moment and come back to it if required, hard enough to find time to change my oil at the moment.
 

·
Registered
Joined
·
15 Posts
Reviving this because I have the same code and similar situation. First my "gas cap loose" message popped up, then a couple hundred miles later the SES came on with code P0456. I've checked all the hoses, none seem to be damaged or leaking. I pulled and tested the the purge valve and the vent valve, both cycled. There are no apparent cracks in the carbon canister. The o-ring on the vent valve is in great condition.

I went to the local dealership to get a gas cap. They want $56, and I refuse to pay that. My gas cap has part number 17251 ZV20A on it. Looking for that online, I can't find that part anywhere. I also can't find anything that says it's a direct replacement for that part.

This is for a 2011 Xterra, 4x4, auto, X trim. Any advice or information is greatly appreciated.
 
1 - 16 of 16 Posts
Top