Second Generation Nissan Xterra Forums banner
121 - 128 of 128 Posts

·
Registered
Joined
·
8 Posts
Actually I think I was able to answer my own question. Here is just a single article calling out the need to replace the cover too:


The part number called out in that thread is found here:

Wow okay thanks for the heads up, just got done talking to the parts place that had the IPDM and they said they would leave the cover off the order if I only needed the IPDM itself. I'll call them back and tell them to include the cover.
 

·
Registered
Joined
·
2,240 Posts
Also, and I for sure may be wrong, but isn’t a new cover also required for the updated ipdm? Pretty sure I can recall that being a thing. The white ipdm cover not fitting exactly on the black ipdm. Anyone able to verify that info?
Good point. My original cover snaps right in on one side, but not both sides (honestly didn't catch that until now when I went out to look at it). Seems like the black IPDM sits just about 1/8th of an inch too high for both sides to click in. The other issue is the fuse/relay diagram will no longer match up. Clearly, you don't want water and dust and dirt getting in there so I definitely recommend the new cover. I have had my Xterra through numerous car washes and a few slushy/snowy days and have had zero problems, but for $12 why risk it? I just ordered the new cover off Ebay for $13 shipped.
 

·
Registered
Joined
·
129 Posts
Good point. My original cover snaps right in on one side, but not both sides (honestly didn't catch that until now when I went out to look at it). Seems like the black IPDM sits just about 1/8th of an inch too high for both side to click in. The other issue is the fuse/relay diagram will no longer match up. Clearly, you don't want water and dust and dirt getting in there so I definitely recommend the new cover. I have had my Xterra through numerous car washes and a few slushy/snowy days and have had zero problems, but for $12 why risk it? I just ordered the new cover off Ebay for $13 shipped.
Def the right move. Like the saying goes, an ounce of prevention is worth a pound of cure. Or a stitch in time saves nine. Either way, smart.
 

·
Registered
Joined
·
8 Posts
Okay small update. I received the Black IPDM and Cover and swapped them out pretty easily, it did cause the flashing airbag light to happen. Started the truck up and drove about 10 miles and came back home. Once I parked, it stalled out no code. Tried to start the ruck and it took a few seconds but did turn over, idled for about 5 minutes then died again. this time put up P0335 code crankshaft sensor. After running about five minutes again died and put up another P0335 code. I'm getting the Nissan OEM Crankshaft sensor and the 2 Camshaft sensors tomorrow. I'll try to change those and report back.
 

·
Registered
Joined
·
8 Posts
After changing the 2 camshaft sensors and the crankshaft sensor the truck started right up and I've driven it 150 miles with no issues at all. I would never have been able to do this before, so thanks to everyone who commented and guided me to finally fixing this truck. Any ideas on how to turn off the flashing airbag light? I did the turn the key on off a few times etc. and it worked until i drove about hundred feet and now its back.
 

·
Registered
Joined
·
15 Posts
Now after wheeling a few weeks ago I’ve got the P0340 code, so I’ll be replacing both sensors soon.

For anyone that’s tackling this here’s a great install video for both c shaft sensors:

Ry the Car Guy - How to Replace Cam Position Sensors

And FWIW, I would recommended subscribing to him on YT. He’s got some good Xterra content on his channel.
Thanks for the shout out!! :)
 
121 - 128 of 128 Posts
Top