Second Generation Nissan Xterra Forums banner

1 - 7 of 7 Posts

·
on line
Joined
·
3,453 Posts
Discussion Starter #1
A couple of days ago, I was adjusting my mirrors with my mirror controls, everything was fine, It was going left/up/right/down with no issues.

Today, I come home and I decided to adjust the mirror and it would go up, down, right but it wouldn't go left so I thought maybe its the mirror itself and I flipped to the other mirror and same thing, it would go up, down, right but not left

Is it the mirror control itself?

It's a '12 Pro4x. If this is a dealer issue, I need to get it there before warranty expires.

Any thoughts?
 

·
Registered
Joined
·
5,402 Posts
I'd have to view the wiring diagram but it sounds like it to me.

Edit: just looked at the diagram, yea it should be the switch. It's the only variable in the mirror system.
 

·
Registered
Joined
·
2,316 Posts
If you are still under the 3/36 warranty period it may be dealer covered.

There's not a whole lot to the mirror system. I installed power mirrors on my X a few months ago (base Xterras came with manual ones, if you can believe that.)

The system is a switch, and some wires running to each of the power mirror harnesses in the door. If BOTH mirrors are responding the same (i.e. left is out on both) I'd tend to think it was he switch. See if you can wiggle the harness behind the switch / make sure its fully in. If you need a new switch, its easy to change and IIRC about $30.
 

·
Premium Member
Joined
·
2,299 Posts
Have you worked on anything in the doors lately?

When I put the turn signals on my mirrors the mirror control wires got pinched between the body and mirror housing when I put it all back together exposing one of the bare wires to the door frame. Mirrors worked similarly to what you described after that even though I repaired the wire. I looked at the diagram for a fuse but as snowtrout said, there is nothing but the wires and the switch. Must have fried the switch when I tried to adjust the mirrors with that bare wire on the body.

Truck was only 5 months old at the time and I probably could have gotten it replaced under warranty but since I knew I had broken it myself I just bought the switch for $25 and replaced it myself.
 
1 - 7 of 7 Posts
Top