Second Generation Nissan Xterra Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,049 Posts
Discussion Starter #1 (Edited)
I decided to add a LED light bar to the X and ended up buying a 2 row 180w 30" with Epistar LED's off eBay for a whopping $88 with free shipping. I'm a gambler, so for $88, I figured I'd take a chance. It is a spot/flood combo at (supposedly) 30 and 60 degree angles. I didn't buy it for long range - Have my Hella's for that - so a wide flood was my goal.

I know, I know... It's a "cheap" Chinese made one using "inferior" Epistar LED's. Fine. I'm okay with that considering the price. Anyway, I fabricated my own mount using a piece of 2" x 1/8" flat stock steel. Another $10 from Home Depot. Miscellaneous hardware to upgrade the bolts that came with the bar, some vibration isolators (rubber washers), 12 gauge wiring and using an extra switch I had been using for the factory fogs and voila!

Pics






Here's the video link to youtube showing the difference it made. LED Light Bar Vid
 
  • Like
Reactions: Wyo Wolverine

·
Registered
Joined
·
561 Posts
Out of curiosity when did you get this from amazon? and what brand is the bar? Just did a quick search and didn't see an $88 bar.

Great steal! That makes me really consider getting one!
 

·
Registered
Joined
·
1,049 Posts
Discussion Starter #8 (Edited)
Out of curiosity when did you get this from amazon? and what brand is the bar? Just did a quick search and didn't see an $88 bar.

Great steal! That makes me really consider getting one!
Typical of these light bars - the prices keep dropping. Check out this link eBay Search 180w LED Light Bars

Prices are now in the $78 range...

BTW - in the video, I wasn't driving and didn't really get the full view of how good this light is. Last night, I had a chance to see it on a dark country road. The center spot is clearly defined and large. The flood pattern goes from edge to edge of your viewing angle. I did have a scare though. When I first tried to turn it on, nothing happened. AARRGGH! I thought for a moment "Great. One day and it's broken"... Turned out that the ground wire wasn't connecting good enough. Tightened it up and all was working. Phew.... Keep in mind that during the install, my first try turning it on blew a fuse. I replaced the fuse and it blew again. Thought maybe I had a bad light (see the paranoia?). It was my fault though. I originally tried running the power wire through the factory hole in the roof (for the nav system?). There is a large nut that the factory wire goes through and I thought I could run the power wire there too. When I tightened up the nut, it shorted the power wire to the body. I ended up drilling a 1/4" hole in the roof, which I was trying to avoid, and used a grommet and sealant around the wire. I also used heavier 12 gauge wires, since this light pulls about 15 amps. I used one of the bolt holes that secures the air dam to the roof as a grounding point. I may change that if I have another grounding problem like I had yesterday.
 

·
Registered
Joined
·
2,010 Posts
Nice! The lighting looks pretty good for $88. Would you happen to have a pic of the X from far away. Wanted to see the whole pic of the X and light together.

Thanks!
 

·
Registered
Joined
·
1,049 Posts
Discussion Starter #10
Nice! The lighting looks pretty good for $88. Would you happen to have a pic of the X from far away. Wanted to see the whole pic of the X and light together.

Thanks!
Here ya go.



 

·
Registered
Joined
·
1,049 Posts
Discussion Starter #11
Night shot... In a mall parking garage... LOL NOOOOO!!!!! A "MALL CRAWLER" PIC! Aaaarrrgghhhh!

 

·
on line
Joined
·
1,739 Posts
Very nice.
 
1 - 13 of 13 Posts
Top