Second Generation Nissan Xterra Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3,592 Posts
Discussion Starter #1
So my leaf springs squeak like mo fo's. When it started I thought it was my bushings, only at 20 000 kilometres I replaced them anyways. Leaf bushings and shackles, defiantly my springs.

WD-40 fixes it but only for a few days, if I'm lucky. I haven't experimented with anything but wd-40

So just wondering If anyone had any tips to get rid of this issue.

Thanks in advance


Sent from AutoGuide.com App
 

·
on line
Joined
·
1,113 Posts
Graphite lube works, it comes in a spray can. I found some at napa a few years back. Now I just let it squeak, I only hear it backing out of the driveway anyway.
 

·
on line
Joined
·
465 Posts
I used a pressure washer to spray off the leaf springs. Then when the springs were dry to put some moly grease on the spring pads between the leaves. Worked for me.
 

·
Registered
Joined
·
2,325 Posts
I lifted my truck on jacks and let the rear axle droop make spaces in between the leaves, then used an air gun to clean them all out. I then used the new WD-40 White Lithium Grease and sprayed it in between all the leaves. The next time I do it I will use a dry lube though because the lithium grease attracts dirt a little bit.

No squeak after, much much better.
 

·
Registered
Joined
·
1,011 Posts
I thought I'd read that greasing your leaves was actually bad for them. I just spray mine with water every time I wash the X. No issues so far.
 
1 - 9 of 9 Posts
Top