Second Generation Nissan Xterra Forums banner

1 - 7 of 7 Posts

·
on line
Joined
·
962 Posts
Discussion Starter #1
I was driving around tonight when suddenly my A/C light turned off and it smelled like burning something or another. That smell went away, but the light never came back on. I parked the car, tunred it off and restarted it, but no luck. All week it's been smelling wet in my car when the A/C came on and my friend felt a drop of water on her foot in the passengers seat fall from under the dash.

I'm approaching 60,000 miles >400 miles away...are things going to start crashing and burning? Will my A/C be fixed under warranty?
 

·
on line
Joined
·
1,574 Posts
try resetting the ECU. i know thatll be a beotch with your HU and wht not, but its worth a try before taking it in
 

·
on line
Joined
·
552 Posts
shutterman0991 said:
I was driving around tonight when suddenly my A/C light turned off and it smelled like burning something or another. That smell went away, but the light never came back on. I parked the car, tunred it off and restarted it, but no luck. All week it's been smelling wet in my car when the A/C came on and my friend felt a drop of water on her foot in the passengers seat fall from under the dash.

I'm approaching 60,000 miles >400 miles away...are things going to start crashing and burning? Will my A/C be fixed under warranty?

As long as you are still under warranty I don't see why they wouldn't fix it.
 

·
on line
Joined
·
17 Posts
the only thing that has gone wrong with my x is the fuel pump i am on the 3 pump now and i am at 75000miles
 
1 - 7 of 7 Posts
Top