Second Generation Nissan Xterra Forums banner

1 - 6 of 6 Posts

·
on line
Joined
·
10,133 Posts
Discussion Starter #1
well, today i was installing an aux fuse box and I pulled a dumbass move. I broke off one of the studs on that funky fuse box thingy that attaches to the positive battery terminal. Don't bother asking how, cuz it was, as i like to call it, a stoner moment. In the pic below, it's the post by where it says "Tap".

So, i'm guessing i need to replace the whole damn thing. Does anyone know what the part # is for this thing? Any help would be greatly appreciated.
 

·
on line
Joined
·
617 Posts
Its a fusible link rated at 140A to the alternator. There are 5 further fusible links built into the box ranging from 60 to 100 amps.
 

·
on line
Joined
·
10,133 Posts
Discussion Starter #5
Alright...here's the part #24380-89914 for anyone who needs it. Not bad at all...only $31.

Side story - they parts guy at the stealership saw my rig and automatically said "you know you voided your warranty by doing all that to the truck". So, I told him that if anything ever happened to my truck and they declined to cover it under warranty, that i would need it in writing as to why my aftermarket stuff caused the problem. His response - "you'd have to call 1-800-NISSAN1 for that". I laughed in his face. Besides that though, he was drooling all over the truck.
 

·
on line
Joined
·
1,864 Posts
:clown: Great info for my X file, thanx Creek--

-- :geek: :geek: ---JIMBO
 
1 - 6 of 6 Posts
Top