Second Generation Nissan Xterra Forums banner

1 - 20 of 58 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
PROBLEM: Blower motor only works on 4, and AC does not blow at all.

ISSUE: Blower resistor card is bad.

SOLUTION:

1. Blower resistor card can be purchased from dealer for approx $50.00

2. Find resistor card under glove box. It is attached to a white electrical connector. Remove the two screws holding the resistor card in place, and the entire unit will drop right out.

3. Attach new resistor card to the white electrical lead, and slide back into place, and insert the 2 screws.

Total time approximatly 5 minutes.

Note: the dealer wanted 2 hours labor @ $90 each to do this, claiming it was extremely difficult and time consuming. Nonsense. This part goes frequently in Nissans (I've replaced mine twice now) so might as well learn to do it yourself.
 

·
Registered
Joined
·
7,130 Posts
My AC still doesn't work after replacing the resistor and control panel.
Anybody know if there's a AC relay and where is it?
Looked in the fuse box but it isn't listed
 

·
Registered
Joined
·
3,592 Posts
nice post.. to start with... This will come handy for a few folks.
 

·
Registered
Joined
·
504 Posts
nice post.. to start with... This will come handy for a few folks.


Yes this will!!!


My blower will only work on 1,3&4.

# 2 does nothing. But my a/c works. So I assume there is a resistor pack for each setting???

I just call Nissan and order in a resitor pack for #2 switch setting then??
 

·
Registered
Joined
·
504 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #8
Yes this will!!!


My blower will only work on 1,3&4.

# 2 does nothing. But my a/c works. So I assume there is a resistor pack for each setting???

I just call Nissan and order in a resitor pack for #2 switch setting then??
My blower worked only on 4 and no AC, but it appears from the responses here that any combination of the settings could be impacted.

Good news is that there is only one resistor card and it is very easy and failry cheap to replace. Part is $50 from dealer - probably could get it cheaper elsewhere.
 

·
Registered
Joined
·
504 Posts
WOW....... I just called the dealer, they have one in stock. $102 plus tax. I called Napa and they have to order it, $110 plus tax. I called another parts store, and $102 and good ole tax again.


I checked ebay, and shipped it's $70.


I'm going to the dealer tomorrow and I'm going to try and see if I can get some kind of discount. I got my alignment there and already bought a couple parts as well. I'll talk to the manager.

I hate how automotive parts are soooo much more expensive than the states.
 

·
Registered
Joined
·
166 Posts
I need to replace mine as well...much like Wheeler, mine works on 1/3/4 but 2 is dead probably because that is the one I use the most. I can't believe how expensive these are. Even at $50 I think that is ridiculous. I remember I had to replace one on my old Ford focus and it was like $19 at autozone. Anyone find a replacement for cheaper than $50?
 

·
Registered
Joined
·
504 Posts
I ended up at the dealer today. I talked to the parts manager and now get a so called discount. Paid 77tax in for the resistor. Fan works perfect now. Thxs for the offer though on yours for $60.
Posted via Mobile Device
 

·
Registered
Joined
·
9 Posts
Where can you find that part on the net? With which part number?
Position 2 is not working for me, looks like that weak part failed...
 

·
Registered
Joined
·
12 Posts
Hey Jerseyparts, I tried clicking on your link but it didn't go to the resistor. I also searched the website but couldn't find it. Can you post the link again. Mine just went out today!!!!
 

·
Registered
Joined
·
52 Posts
I'm having similar AC issues; where AC only works for a few seconds, some of the blower fan speeds not working, etc.

Sounds like Nissan is having yet another reliability/quality issue which they are not accepting responsibility for.

Thank you for posting the fix - will give it a try.

Interestingly enough, I took my X to the dealer to find out what was going on. Those clowns told me my AC was working fine - they must not have even checked it. For once, I'm grateful for their incompetence/malfeasance; now I can fix it myself and have it done properly!
 

·
Registered
Joined
·
40 Posts
Discussion Starter #19
I'm having similar AC issues; where AC only works for a few seconds, some of the blower fan speeds not working, etc.

Sounds like Nissan is having yet another reliability/quality issue which they are not accepting responsibility for.

Thank you for posting the fix - will give it a try.

Interestingly enough, I took my X to the dealer to find out what was going on. Those clowns told me my AC was working fine - they must not have even checked it. For once, I'm grateful for their incompetence/malfeasance; now I can fix it myself and have it done properly!
Always gotta check what the dealer tells you with your good buddies in the Xterra Forum!
 

·
Registered
Joined
·
52 Posts
It was indeed the resistor card. AC and all blower speeds working fine now. While I was at it, I also replaced the blower motor, as it is the likely culprit causing the resistor card to blow. Was able to find an aftermarket blower motor by TYC on Amazon for about $51. Thanks again to all that have posted about this latest Nissan defect.
 
1 - 20 of 58 Posts
Top