Second Generation Nissan Xterra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,295 Posts
Discussion Starter #1
for the love of god can someone tell me how to remove the secondary o2 sensor clip. Ive never struggled with a connection this bad, I cant see how the F this thing is being held on.

its the green one to gray one.
 

·
Registered
Joined
·
2,295 Posts
Discussion Starter #2
nevermind i finally got it.

it was made easier by first unscrewing and removing the o2 sensor, then i was able to get the cable connection in a better position to be able to depress the little tab. wouldnt it be nice if it said "push" on the spot your supposed to push on.. or even better yet how about all the connection on the entire vehicle just be THE SAME! its like a goddanm puzzle every time!
 

·
Registered
Joined
·
2,295 Posts
Discussion Starter #5
spray with wd-40 and jam a small screwdriver in the push tab. But yeah, I hate those evil connections
I was about to do exactly this but was afraid it would make the whole thing slippery and therefore even more impossible!
 

·
Registered
Joined
·
52 Posts
I have been struggling with this connector as well. I cannot even get the first part disconnected. Just cannot get my hands in there to get a good enough grip on the two connectors to pull them apart-- they are stuck really good together. Whats best to spray on there, WD-40 or I have also heard to use silicone spray or electrical contact cleaner? I haven't gotten to the part where you press the little tab with the screwdriver.

For others who find this thread, here is a good video I found on youtube that goes through removing the front and rear converters and replacing the gaskets and O2 sensors. He disconnects the rear sensor at 9:14. He just gets it right off there like its nothing:

 

·
Registered
Joined
·
2,017 Posts
It seems like all your sentences end in an exclamation mark! You need Jesus brah lol. Glad you were able to get the damn thing apart. I hate those freakin' connectors!
 
1 - 8 of 8 Posts
Top