Second Generation Nissan Xterra Forums banner

1 - 20 of 30 Posts

·
on line
Joined
·
191 Posts
Discussion Starter #1
I seem to remember a recurring problem with the hood latch posted here somewhere. I have not been able to find anything.

Mine is driving me crazy. It sounds like someone sticking a pterodactyls beak into a pencil sharpner. I have traced the noise to the hood latch. Has anyone delt with this before? Some kind of adjustment of the stops maybe?

Thanks
 

·
on line
Joined
·
547 Posts
funny thing is, right after i replied to this thread, mine started doing it....it drives you crazy by sounding like a sqweeky hampster wheel with every bump and every time you close the door!! unscrewed all three bump stops a 1/4 turn and lubed up the latch mechanism with some silicone. worked like a champ!
 

·
on line
Joined
·
191 Posts
Discussion Starter #9
I think this might be a case of a "Curse of The 05" because my stops are not adjustable. They are just several discs of rubber, turning them does nothing. Maybe they changed them? Thaks for the help.
 

·
on line
Joined
·
14,014 Posts
BIGTOM726 said:
I think this might be a case of a "Curse of The 05" because my stops are not adjustable. They are just several discs of rubber, turning them does nothing. Maybe they changed them? Thaks for the help.
YEAH! Same here dude, I tried adjusting mine and they're just one big piece of rubber.
 

·
on line
Joined
·
61 Posts
miles said:
YA! no curse on the 06's...

Whatever! My '06 squeaks like a mouse orgy. I've adjusted the stops and everything...goes away for about two days then it's just god damn embarassing driving down a bumpy road. I need to try greasing up the hood latch.
 

·
on line
Joined
·
1,716 Posts
1 - 20 of 30 Posts
Top