Second Generation Nissan Xterra Forums banner

1 - 9 of 9 Posts

·
on line
Joined
·
47 Posts
Discussion Starter · #1 ·


Pic was taken Friday night, we went up to North Conway, NH for a weekend trip but came back early so as not to get stuck in the storm. Bought the Xterra new at the end of Feb '06 so in 22 months she's racked up 37,000 miles, which I must admit was mostly highway between Boston and family down the Cape plus 2 trips to NYC. We were offered the extended warranty but turned it down as there haven't been any major problems and not too worried about the diffs as the only time the 4wd is used is in snow, I can't see any off roading in the near future. Last Thursday took it in to have it looked at & the brake pads have about 50% life left on them, I had an Amsoil oil filter installed as well as Amsoil 5w30 oil which I plan on running both to the advertised 20-25k miles. Also drained the factory fill from the front and rear diffs (I know it was left in there a lil longer than it should've been) and those were filled w/ Amsoil severe gear 75w-90. Hopefully only other things I'd need to take care of is flushing the brake fluid, steering fluid, & coolant once we hit the 2 yr mark. Kudos to a durable and well built truck! :cheers: [/img]
 

·
on line
Joined
·
1,361 Posts
I am at like 15,500 after 15 months of ownership. Although I will rack up over 1500 around xmas.
 

·
on line
Joined
·
28 Posts
So, is this a thread to brag about how much we get to drive our lovely Xs. I setting at 10 months with 17700 miles on my '07 SE 4wd. And those are drove on weekends, as we drive my wife's CRV to work M-F. I wouldn't say I do a lot of heavy wheeling, but since I live down several miles of dirt roads (loose sand mostly), followed by some of the worst paved roads in the county, I do give mine a regular workout.
 

·
on line
Joined
·
707 Posts
Got ours in March of 06 and are at 35700 or so. Commuting, a trip to Denver and several trips to the mountains. I now have a 10 mile round trip for work instead of the nearly 70 before so the miles aren't adding up like the once were.
 

·
on line
Joined
·
129 Posts
Bought our X in Feb. '06 as well, and we just rolled 40,000 twp days ago. And I have to say, NO ISSUES YET AT ALL, other than a torn upper ball joint boot that they replaced with no questions asked.. with the lift!
 

·
on line
Joined
·
255 Posts
SKW, looks like you know how to treat your vehicle. Glad to see you don't mention any clutch problems. A 'very few' people on other forums have really complained about the clutches in their '06s.

I had a 528i, mine was a '79 with a 4 speed manual. Gorgeous car. Dark metallic Blue with Dk. Blue leather. Put Bilsteins on it and made a big difference in handling.
 

·
on line
Joined
·
191 Posts
I bought mine used in August of this year; I hit the tach when I left the dealership...three days ago that tach rolled back to zero (meaning that I have driven over 9999 miles!). I love it! I just wish it had a little more power when pulling my snowmobiles up the MTs.
 
1 - 9 of 9 Posts
Top