Second Generation Nissan Xterra Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter #1 (Edited)
Ok so I got this sound out of the blue, it’s hard to explain kind of sounds like a circular saw but not as loud but th saw spinning sound or like a pump sucking air. At first I thought timing chain but can’t hear the sound near front of engine. It seems to be coming from near the oil pan area or transfer case area. I hear it with the windows down if I’m pressing gas lightly in gear or in park. I checked my trans fluid levels they are good I know the fluid needs to be changed it’s quite darkish purple looking when I changed the radiator last week. Now ive asked on a few of my Facebook groups one guy though maybe a spin bearing but there is now drivability issues not tapping or knocking or oil pump. Where is the oil pump location on our trucks?

 

·
Registered
Joined
·
2,295 Posts
idk man, hard to hear anything in the vid that sounds concerning.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #3
It’s the Ch Ch ch ch sound when video gets near oil pan. I’m trying to get another video loaded so I can share in here with the gas applied
 

·
Registered
Joined
·
2,295 Posts
hm yeah i can hear it in the second vid. still have no clue what it could be. it does sorta sound like a sucking or vacuum related type noise.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #7
One guy I talked to suggest oil filter whine. But seems odd since filter is in front of engine and this sound like back side. Could it possibly be resonating that bad thru engine? I never knew filters could whine
 

·
Registered
Joined
·
126 Posts
Discussion Starter #8
I planned on changing oil soon here anyway but if per say it’s the pump like on guy suggested is our pump located in the pan like some or is it elsewhere?
 

·
Registered
Joined
·
5,083 Posts

·
Registered
Joined
·
156 Posts
to me it sounds more like a bearing in the trans.

lol also kinda sounds like a family of cicadas
 

·
Registered
Joined
·
126 Posts
Discussion Starter #11
Well I check for metal on oil and don’t see any nice and clean no glitter affect like a spin bearing and seems to be coming from right in front of oil pan. Since I needed a oil change I’m gonna try and see if it’s filter whine. They say if the filter is bad it messes with the pressure from the pump. 12hra of searching and I finally found a video of the same sound I have
 

·
Registered
2012 Nissan Xterra S
Joined
·
945 Posts
The oil filter whine is real. Can confirm. I just stick with the shitty Nissan filters now. How long has it been since you've last changed your oil? IIRC when using non OEM filters on my X I noticed the whine when I got close to 5k miles on the filter.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #15 (Edited)
Got about 3500 miles maybe I’ve changed my oil 3tikes and have only put about 9000 miles on it since I bought last December. Never heard it before and have been using wix filters I’ve never used oem since Nissan is about 40mim from me
 

·
Registered
Joined
·
126 Posts
Discussion Starter #17
Oh yea I was planning on doing the fluid just got done doing the rad about a week or two ago and have. Even working on front suspension again so haven’t been driving a ton except test runs after installing and setting my alignment. I got 3 gallons of fluid to flush thru just gotta get it in garage to work on it. Summer meds int here right now and it’s getting cold out lol.
 

·
Registered
Joined
·
126 Posts
Discussion Starter #18
Maybe the sound is coming from the Torque converter. That is very nearby. I would update that fluid before any part guessing.

That sounds way different and sound don’t change when in gear and o lay seems to be at low rpms, it could be a possibility a torque converter but I have seen more and more of this filter whine which seems to sound like it or pump which if im correct that’ll suck cause o think the pump is in by the timing chain.
 

·
Registered
2012 Nissan Xterra S
Joined
·
945 Posts
Most excellent. FWIW I sometimes run the cheapo Supertech filters from Walmart. They're only a few bucks and "made in the USA" but they most closely resembled the Nissan OEM filter to me. (real small and crappy looking). I think Nissan charges $8 a filter so could be some savings there for you plus added convenience. Supertech ST6607 IIRC... Just put one on last night actually.
 
1 - 20 of 24 Posts
Top