Second Generation Nissan Xterra Forums banner

1 - 8 of 8 Posts

·
on line
Joined
·
3,262 Posts
Discussion Starter #1
Okay guys, thankfully its not my X... but my sisters Heep. I took it for a test drive today because she is selling it. I wanted to see if it needed to be tuned up or something... Well apparently it needs more than a tune up.... Radiator fluid started leaking out. If thats not bad enough, I cant find out where its coming from. The radiator, and hoses seem fine. Does this mean what I think it means??? Could it possibly be... dont say it!!! (Is the block cracked or something??)
 

·
on line
Joined
·
15,651 Posts
It could be a feeze plug in the block (more likely than a crack).

Can you actually see it leaking or is the rad/overflow just not full?

If you are running the car and turn on the heat do you smell anti-freeze? The leak could also be the heater lines or the heater core.
 

·
on line
Joined
·
3,262 Posts
Discussion Starter #4
muzikman said:
It could be a feeze plug in the block (more likely than a crack).

Can you actually see it leaking or is the rad/overflow just not full?

If you are running the car and turn on the heat do you smell anti-freeze? The leak could also be the heater lines or the heater core.
Yeah its definitely leaking!!! More like pouring. It stopped and the engine started to get hot... i turned it off, put in about half a bottle of fluid... no leaks.... cranked it up and the fluid started pouring out again.

I smell no radiator type smell when I have the heater on or AC except the smell from the outside... but nothing from the vents!

How much would it be to replace any of those components??? DIY and/or have a shop do it?
 

·
on line
Joined
·
238 Posts
Ok, don't panic too much yet.

Find you water pump and check it's weep hole. Your water pump bearings could be bad and just need to replace it. Mine started kinda slow and after a couple days it was peeing pretty good. It's an easy job and for my 4cyl wrangler the water pump was around $25. There's a reason those are cheap.

If her's is a 4cyl jeep it is on the front of the engine to the right of the fan pully I believe. The weep hold is half way around one of the sides of it I think.
 

·
on line
Joined
·
246 Posts
Turtle said:
Ok, don't panic too much yet.

Find you water pump and check it's weep hole. Your water pump bearings could be bad and just need to replace it. Mine started kinda slow and after a couple days it was peeing pretty good. It's an easy job and for my 4cyl wrangler the water pump was around $25. There's a reason those are cheap.

If her's is a 4cyl jeep it is on the front of the engine to the right of the fan pully I believe. The weep hold is half way around one of the sides of it I think.
I secound the water pump. When they go they let out tons of coolant.
 
1 - 8 of 8 Posts
Top