Second Generation Nissan Xterra Forums banner

1 - 13 of 13 Posts

·
on line
Joined
·
2,902 Posts
Discussion Starter · #1 ·
1) "bits" in paint on roof. They have popped up over the past month...

they are not chips they are actually under the clearcoat and paint and rising up....


2) pinging/knocking

occurs once truck is warmed up. i have just put in some techron so maybe that will fix, i will still mention it to them.

3) creaking/rattling windows

they creak and rattle especially when partially down

4) ticking sound at idle in engine and accelerating sounds like it's a turbo....


too bad they don't make them in japan anymore....


talked to SM and have appt for next wednesday..... can't wait to see what they say.. I have always had problems the first time around getting them to fix. they usually try to pass it off as "normal".
 

·
on line
Joined
·
2,938 Posts
The ticking at idle is normal. I believe it has to do with the variable timing.
 

·
on line
Joined
·
2,902 Posts
Discussion Starter · #3 ·
well i figure, i might as well hear it from them..... i am really concerned about the window noises and the paint... the other stuff is probably "normal" but I want to make sure.....
 

·
on line
Joined
·
244 Posts
XVTer said:
When mine was new, the windows rattled, but I think that I got enough dirt and dust in there now that they don't really bother. Let us know how it goes, though
Same problem with the drivers side window. I took it to the dealer once and they said they couldn't duplicate the rattle. So, 8 months later, no rattle. It finally quit. I'm happy
 

·
on line
Joined
·
1,320 Posts
There's a TSB for the window rattle... i believe most have replacing the actuator or something.
I'd print out the TSB and take it in with you.
 

·
on line
Joined
·
240 Posts
Mine is going in soon for the window thing too. The passenger one creaks like crazy!

I also have a whistling/chirpping sound when accelerateing. Its around 2500-3000 rpm and sounds a little cyclic like a bad bearing on something? We'll see what they say.
 

·
on line
Joined
·
2,902 Posts
Discussion Starter · #8 ·
the results of the visit:



1) "bits" in paint on roof. They have popped up over the past month...


body shop told me it is "dirt"; under the paint...if it were them, they wouldn't touch because nissan piant from factory is much better and it won't worsen... we shall see and i have it documented...


2) pinging/knocking

occurs once truck is warmed up. i have just put in some techron so maybe that will fix, i will still mention it to them.

they put it on the obd tester and drove it around with me, they heard it but nothing showed out of specs... it has been documented, nothing they can do....recommended changing gas type...brands...

3) creaking/rattling windows

they creak and rattle especially when partially down
we could not duplicate but they said if it gets worse and is more pronounced, they will replace regulators...
documented.

4) ticking sound at idle in engine and accelerating sounds like it's a turbo....
no ticking anymore, since last oil change and turbo sound is normal. it is the intake...
 

·
on line
Joined
·
564 Posts
silverflash said:
...2) pinging/knocking

occurs once truck is warmed up. i have just put in some techron so maybe that will fix, i will still mention it to them...
According to the owner's manual, some pinging is normal...
Owner's Manual said:
However, now and then you may notice
light spark knock for a short time while
accelerating or driving up hills. This is not a
cause for concern, because you get the
greatest fuel benefit when there is light
spark knock for a short time under heavy
engine load.
I frequently hear a short ping while accelerating.

Rob
 

·
on line
Joined
·
2,902 Posts
Discussion Starter · #11 ·
experiment: truck has 11,000 miles on it....

put 93 shell gas in last week. stopped pinging.

just filled up with 87 shell with 1/4 of the 93 left, started pinging again.

i dumped 2 bottles of techron "treats up to 12 gallons" into the tank and changed the air filter. Still pings, but not as bad possibly. I will see today at lunch.....

so i get the ping right after the trans shifts into the next higher gear then it goes away. It doesn't seem to be there on heavy acceleration, just light acceleration and at the lower rpms. Is this considered "heavy engine load"?

how can you "fix" this pinging? It didn't do this when new. Is it carbon deposits? Will the techron clean those up sufficiently? Will a dirty air filter cause pinging? I would think it would righen the mixture though... Or should I even care? It sounds embarrasing though to have such a nice truck, but have it pinging all the time.... remember, the dealer said computer stuff was all in specs....

thanks...
 

·
on line
Joined
·
3,285 Posts
Since I started using 89 octane, I have not had an issue with pinging. Many people will suggest that the timing is off if the truck is pinging using 87.

My take on the whole 87 vs 89 debate is that 87 might not actually be 87 - it could be 85 or 86. Therefore, the 89 could be 87 or 88.
 

·
on line
Joined
·
2,902 Posts
Discussion Starter · #13 ·
yes! i thought of that too because maybe in this day of 3.00 gas, they are being cheap in trying to get as much profit as possible. either the refinery or the station, i'd bet the refinery.....


I will try 89 next.... i just don't want to mask a problem if there is one...


thanks....
 
1 - 13 of 13 Posts
Top