Second Generation Nissan Xterra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1 (Edited)
Resolved


Bought my X with known front-end damage. Everything looks and works fine, except the position of the headlights. Nothing is obviously out of place to me, so I was hoping you guys could help with suggestions or point me in a direction to solve this. Nothing major; just an aesthetic annoyance that tickles the OCD. The space between the light and fender. The bumper matches the fenders fine.










I've already thought about putting spacers underneath the headlight brackets, but I'd rather do that as a last resort, and if I can match the other mount after doing so.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #6 (Edited)
^ I can't imagine how it disappeared, unless someone forgot to reinstall it after repairing the damage from the accident. Additionally, the one remaining is installed upside down. :violent1:

I'm looking at this to get an idea of how to go about replacing these since the FSM makes no mention of doing so: http://www.clubfrontier.org/forums/...nt-body-mounts-2nd-gen-front-end-clunk-81941/
but I'm running into a problem: when I try to lift the body in the front, the frame lifts right along with it. Do I need to loosen our second mount? Unlike the Frontier, we don't have that second mount immediately near the front. Unless I'm mistaken?

EDIT: What am I talking about? We have the same frame. Anyway, I loosened the second body mounts, and the frame still comes up when I attempt to lift the body.

 

·
Registered
Joined
·
118 Posts
Discussion Starter #7
There we go.





Turns out the body mounts were the sole cause of this fitment issue. I finally got the body up after getting desperate and loosening the three mounts behind each front. I used the emergency jack to lift the body by the pinch welds. Even then, the frame still rose, but not as much as the body. At maximum lift, there was plenty of space to pop the mount in the frame.
 
1 - 7 of 7 Posts
Top