Second Generation Nissan Xterra Forums banner

1 - 17 of 17 Posts

·
on line
Joined
·
552 Posts
Discussion Starter · #1 ·
Hey guys, I just finished installing the fog light kit on my Xterra and i was wondering about the position of the lights. There is a little bit of space all the way around both of the lights and it looks like they could be pushed forward to sit flush with the plastic. I couldn't get them to sit flush though so i was wondering if this is how they are suppose to be. If not, any tips on how to get them to sit properly?
 

·
on line
Joined
·
2,072 Posts
Did mine this weekend and I have the same issue. I need to look at an OR Xterra to see what they look like. Iwas told by someone else on the forumn that this is normal.

Also, it was suggested that the clip for the screw should be placed on the tab on the bumber versus the tab on the light bracket. I haven't gone back to make that change yet.
 

·
on line
Joined
·
552 Posts
Discussion Starter · #4 ·
yea bueller, that is what i did. I figured that the clip should go on the bumper after working with it for little bit. I worked on it for a while but couldn't get them to sit flush. I really like having the fog lights but the install was a little scketchy. It just doesn't look clean...
 

·
on line
Joined
·
113 Posts
Well i dont have my camera with me, but I have a stock 07 SE and there is about a 1/4-5/16th of an inch gap between the lens and the bumper.
 

·
on line
Joined
·
1,864 Posts
:clown: -On my stock, unmolested, '06 Xterra--

--Both fog lites, sit back 1/4 inch, from the front, fender, facia--

-- :geek: :geek: --JIBO
 

·
on line
Joined
·
971 Posts
helofixer said:
Well i dont have my camera with me, but I have a stock 07 SE and there is about a 1/4-5/16th of an inch gap between the lens and the bumper.
JIMBO said:
:clown: -On my stock, unmolested, '06 Xterra--

--Both fog lites, sit back 1/4 inch, from the front, fender, facia--

-- :geek: :geek: --JIBO

PICS PLEASE!!!
 

·
on line
Joined
·
113 Posts
Ill try tomorrow to get some pics for ya. But take my word for it. there is about a 1/4 inch gap.
 

·
on line
Joined
·
1,574 Posts
sorry to jack the thread here, but im about to buy some oem fogs, where did you all buy from?
thanks
 

·
on line
Joined
·
552 Posts
Discussion Starter · #12 ·
Well it sounds like this is somewhat normal. It's still kind of weird though.
 

·
on line
Joined
·
1,420 Posts
there needs to be a gap.....heat would melt bumper...
 

·
on line
Joined
·
2,072 Posts
Jasontamu said:
there needs to be a gap.....heat would melt bumper...
That's what I was thinking too!!
Thanks for the pics, I will leave mine alone now!!

What a team of X owners we are!! :cheers:
 

·
on line
Joined
·
552 Posts
Discussion Starter · #17 ·
Yes indeed! Thanks for all the replies and the pictures to clarify. I'm glad that's all cleared up now.
 
1 - 17 of 17 Posts
Top