Second Generation Nissan Xterra Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
3,024 Posts
Discussion Starter #1 (Edited)
So turns out that it was a leak from my radiator. good news, so they replaced it under warranty. so now i don't have to worry about the SMOD. the dealership also told me my heat shields were about to fall off and needed to be repaired.. so i told him no, i have a new clamp at home. ok. I pick it up today, and he's reading off the items... repaired heat shield..49$ i say..woo, I told you not to do that.... so we have a little talk. telling him again that i have a clamp at home for 3$ that will fix that. and he tells me, it's going to take more then 1 clamp....I say, okay. 2 clamps for 6 bucks.... so he gets the manager to take it off the bill. so i got it repaired for free.. double score!! =) :drink:









So I've noticed that past few mornings, ( not every morning) but a puddle under my truck (green). It's under the reservoir tank for my coolant. all of the sudden, my truck is spitting out its antifreeze. the weather has cooled down, so it is not 100 degrees anymore. I only drive around with the air on when the family is in the truck....
one morning, I started the truck with my auto start, and after a moment, i saw the overflow spill out. When i went to check the coolant level another time, while the truck was cold, I tried to open the cap, coolant spilled out. both the over flow and the main cap on the radiator. I can smell the antifreeze burning while driving.
There is no sign of SMOD on the cap. I'm taking it to the stealership on wed. 2 years ago i did have the head gasket replaced due to over heating and no oil pressure. so i hope it has nothing to do with that. but any help or ideas with this matter would be greatly appreciative!!

I tried tonight, and the heat works fine, and the air works ok. I have never been happy with the air conditioning in this truck anyway. but according to the stealership, the air works fine!! whatever!!

BTW.... the truck has 68000 miles on it and is an 05 SE. Auto.

:banghead:
 

·
Registered
Joined
·
2,621 Posts
Having coolant spill out the rad cap is normal but out of the overflow tank aint when the truck is cold. Could be your main rad cap is not holding pressure and is filling the overflow tank. Is the truck running normal temp when driving ?
 

·
Registered
Joined
·
3,024 Posts
Discussion Starter #4
the gauge is reading normal while driving. when i check the radiator, the main cap is holding pressure, so when i release the cap, i can hear the pressure release. and i know it isn't leaking out while driving, well, i don't think so. but when the truck is cooling down is when it leaks.
 

·
on line
Joined
·
1,416 Posts
If coolant is being released immediately after a cold start that is very unusual. I'd be suspicious that there is a head gasket failure that is over pressurizing the cooling system.

How much coolant are you loosing? You say it leaks when cooling down, are you watching the coolant be released from the reservoir?

Jeff
 

·
Registered
Joined
·
3,024 Posts
Discussion Starter #6
i'm worried about the head gasket as well. it doesn't spill out right after i turn the truck off, it usually happens over night. and it didn't overflow last night. and I've only seen it spill out once, and that was when i started the truck up one morning.

I just went out to check the level again. when i opened the reservoir tank and released the pressure, you can see the coolant fill up and then spill out.

i take it in tomorrow so we shall see what they have to say.

and it may be a cup of liquid when it does overflow.
 

·
Registered
Joined
·
3,024 Posts
Discussion Starter #8
check out the spring on the overflow cap - mine went bad and was causing the leak.
hmmmm... didn't think about that.......but like i said, i'm dropping it off in the morning.....under warranty, so we shall see.... plus the timing belt whine is getting loud from what i noticed yesterday,when i was under the hood with it running... so i'll have them take a look at that also!!
 

·
Registered
Joined
·
3,024 Posts
Discussion Starter #9 (Edited)
So I get a phone call from the dealership today.... guy was like, you have a leak in your radiator, that is the fluid you are seeing. needs to be replaced. also your tie rod ends have lots of play in them and should be replaced as well. it's going to be a little pricey!! That isn't covered under my extended warranty? i ask... Oh, you have an extended warranty? Yes, i told you this when i dropped my truck off. It's not coming up on the computer, do you have your paper work on it? I'm at Sesame place in PA...... so not on me. oh okay, let me double check... he calls back 20 minutes later, according to your records... both of these will be covered under your warranty!!

So a brand new radiator for my 05 SE is getting put in tomorrow, and some new tie rod ends courtesy of Nissan North America... with a 50$ co-pay. he also tells me my alignment is off, it must be pulling pretty hard. Not at all i tell him!!! but, i tell him to do it anyway. it can't hurt!!

SO, in a few days we will see if it was this leak i have been seeing, or something fishy going on with my cooling system..


when i double checked my radiator cap before dropping off the truck.....no signs of the SMOD, so i'm hoping the leak wasn't part of the transmission issue. will double check that in the morning without 10,000 kids running around screaming in the background...lol
 

·
Registered
Joined
·
489 Posts
So I get a phone call from the dealership today.... guy was like, you have a leak in your radiator, that is the fluid you are seeing. needs to be replaced. also your tie rod ends have lots of play in them and should be replaced as well. it's going to be a little pricey!! That isn't covered under my extended warranty? i ask... Oh, you have an extended warranty? Yes, i told you this when i dropped my truck off. It's not coming up on the computer, do you have your paper work on it? I'm at Sesame place in PA...... so not on me. oh okay, let me double check... he calls back 20 minutes later, according to your records... both of these will be covered under your warranty!!

So a brand new radiator for my 05 SE is getting put in tomorrow, and some new tie rod ends courtesy of Nissan North America... with a 50$ co-pay. he also tells me my alignment is off, it must be pulling pretty hard. Not at all i tell him!!! but, i tell him to do it anyway. it can't hurt!!

SO, in a few days we will see if it was this leak i have been seeing, or something fishy going on with my cooling system..


when i double checked my radiator cap before dropping off the truck.....no signs of the SMOD, so i'm hoping the leak wasn't part of the transmission issue. will double check that in the morning without 10,000 kids running around screaming in the background...lol
If your tie rods are shot then of course your alignment is out.
 

·
Registered
Joined
·
3,024 Posts
Discussion Starter #11
yes... you are right! but i couldn't tell that it was out... it never pulled except under hard breaking, and in ruts in the street.
 
1 - 11 of 11 Posts
Top