Second Generation Nissan Xterra Forums banner
1 - 20 of 40 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 · (Edited)
Thread Title: "Kid Hauler"

Username: faster

Year: 2007
Make: Nissan
Model: Xterra
Trim: S 4X4, Automatic
Color: Super Black

BUILDNAME: Faster's Kid Hauler

MODS:

ENGINE
• XTP IMS
Dyno max Cat back
Secondary cat "delete"

SUSPENSION
• Nisstec Radflo 2" extended length coilovers, 600lb eibach springs
• SPC Upper Control Arms
• SPC Cam bolts
• Nisstec Deaver AAL
• Nisstec adjustable shackles (lowest setting)
• Bilstein 5125 rear shocks
• 2.5 Degree shims (still slight vibes at 35-37mph)

DRIVETRAIN
Coming Soon

EXTERIOR/ARMOR
• Gobi Passenger Side Ladder

TIRES / WHEELS
• 285/75/16 Duratracs on stealthed stock S wheels

STEREO
• Pioneer AVIC 510BT
• Pioneer AMP (needs install)
• Pioneer Subs in custom enclosure (needs install)

ELECTRICAL
Coming Soon

LIGHTS
• Totron 40" DC (needs wired)

INTERIOR
Coming Soon

RECOVERY GEAR
Coming Soon

No updates really... Just been enjoying her:


Stock:


Suspension Installed:


Gobi:


Zombie Lights:


Updates to come over the next few days / weeks.
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #3 ·
lookin good dude! did you have issues pulling your truck out of the garage after the lift? looks like it might be close! haha...I can't pull my truck in the garage any more =/
I was worried for sure! I had about 2.5" of clearance. Guess my snowboard / fishing pole rack won't be going on/off in the garage. :(
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #4 ·
My long 4th of July weekend:



Everything I read said this should take between 6-8 hours. Yeah... that was wrong. 18 hours later it was all buttoned up. We did spend about an hour on the LCA bolts... we did get them out with the use of a 4ft cheater bar to put radial pressure on the bolt end, then backed the nut off flush with the bolt and smacked it repeatedly with a 25lb sledge... That worked well and didn't have to cut the LCAs. Wrapped up just in time for the UFC fights Saturday night.
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #5 ·
So here's a stupid question... The 5125 rear bils from Nisstec would only mount with the shock body up. I know that they're meant to be mounted either way, but this seems upside down to me. Anyone have these get them to mount with the body down? If so how? Did I not use a big enough hammer?
 

·
Registered
Joined
·
2,797 Posts
So here's a stupid question... The 5125 rear bils from Nisstec would only mount with the shock body up. I know that they're meant to be mounted either way, but this seems upside down to me. Anyone have these get them to mount with the body down? If so how? Did I not use a big enough hammer?
i have the same shocks and i have them mounted with the body down. how come you can't get them to fit that way? they're the same mounts/bushings on either end...
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #7 ·
i have the same shocks and i have them mounted with the body down. how come you can't get them to fit that way? they're the same mounts/bushings on either end...
The bolt that goes through the bottom is smaller than the top mount. Wouldn't fit body down. Lubed, hammered, cussed, hammered some more, finally gave up and mounted body up. Figure it's the easiest part to flip around once I figured it out. I'll take pics one of these nights when I have a few minutes to get into the garage.
 

·
Registered
Joined
·
2,797 Posts
hrmm thats weird...i don't remember having any issues when we installed mine...maybe you can swap the bushings out in the shock? like just reverse them. move the top one to the bottom, and bottom one to the top?
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #9 ·
hrmm thats weird...i don't remember having any issues when we installed mine...maybe you can swap the bushings out in the shock? like just reverse them. move the top one to the bottom, and bottom one to the top?
Tried that... Was afraid to tear the bushing. They seem to be riding just fine the way they are. Put about 50-60 miles on the truck since install and it's a huge improvement over stock, just looks funny.

Now the 600lb springs on the front with no additional weight are a different story. Going over any type of drop off they seem to bottom out quickly... Think they're within a couple inches of max down travel when sitting. May be a good excuse to buy a winch and bumper mount... :eek:ccasion5:
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #12 ·
Gobi and Totron installed, OP updated with pics. Totron still needs to be wired. Hopefully during the kids nap tomorrow I can get it knocked out.

Cheers!
:drink:
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #13 ·
Postponed the totron wiring a few days... Figured I need to wire up my sub amp as well, so I called Jim @ OTRATTW to order a Blue Sea and 'Zombie Lights' switch. Great guy to deal with; answered all my dumbass questions and said he'd ship stuff out tomorrow!

:eek:ccasion5:
 

·
Premium Member
Joined
·
9,791 Posts
NICE! yeah, jim is one of my favorite people. he's good.
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #17 · (Edited)
Came home from work today and had a couple packages waiting. Picked up a cargo cover out of the FS section to keep prying eyes off what ever hobby of the day is back there; sporting clay 'equipment' / zombie repellent, golf clubs, etc. My 3 year old thinks it's a tent and needed a blanket:



The 285 Duratracs showed up too! Waiting on a member to swap out his OR rims, will stealth them and mount these up. My boy trying to help mount them by pushing them on... There was lots of grunting. He said we needed bigger tools. I couldn't agree more:

 

·
Registered
Joined
·
98 Posts
Discussion Starter · #18 · (Edited)
How PlastiDip Saved My Life

The Stealth Fairy visited my house yesterday. The plan was to just do the emblems, but I guess subconsciously I knew I wanted it all black so accidentally bought enough PlastiDip to pretty much do the entire truck.

So as the emblems were drying I started the wheels... Then the back bumper and plastics. Ran out of time before I got the front done. I used PlastiDip just to temporarily see how it would all look in person. Once I've lived with it for a while and decide I want it permanent I'll probably take the parts I want done to LineX.



I will get the front done tonight and post up some more pics. Still have the OTRATTW switch and BlueSea to install to get the Totron functional.


:eek:ccasion5:
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #19 ·
Got the 285s mounted yesterday... Walked out into the shop as they were finishing up to check it out while it was still up on the rack.

Firestone Guy #1, "So why did you put mud tires on this?"
Me: Shake head and walk to other side of truck
Firestone Guy #2, "Hey, want me to put tire shine on these?!"
Me, "Uh. No. Please don't."

I then proceeded to walk back to the waiting room before any more stupid questions were asked.

Droop:
 

·
Premium Member
Joined
·
9,791 Posts
lol. extra shine please!
 
1 - 20 of 40 Posts
Top