Second Generation Nissan Xterra Forums banner

1 - 15 of 15 Posts

·
on line
Joined
·
1,054 Posts
Discussion Starter #1
argh.... i'm annoyed as hell... there's a slight "eeek eeek" noise going on in the front end and I can't figure out for the life of anything what it is. It happens when you first accelerate, not hard acceleration but slow to normal. It doesn't happen each time either, only on occasions, I took it to the dealer and they told me they couldn't replicate it...tempted to try another dealer since old folks are deaf.


also, my x likes to do a small shutter from time to time with the a/c on sitting at idle after driving...maybe once a week it does it, anyone else have that issue or have any ideas i can look into?


:scratch:
 

·
on line
Joined
·
1,054 Posts
Discussion Starter #4
Syndicate, i think that's what i'm going to have to do. I can hear the noise and it drives me nuts, it's not very loud but it's there. I think i'll be bringing it again to a different dealer and try it that way and see if i have any luck.
 

·
on line
Joined
·
149 Posts
A pirate walks into a bar.
The bartender says, "Hey, Pirate! Do you know you have a steering wheel sticking out of your fly?"

The pirate answers, "Aargh! It's drivin' me nuts!"
 

·
on line
Joined
·
15,651 Posts
Karpediem said:
A pirate walks into a bar.
The bartender says, "Hey, Pirate! Do you know you have a steering wheel sticking out of your fly?"

The pirate answers, "Aargh! It's drivin' me nuts!"
I just clicked on this thread to post that joke. :)
 
1 - 15 of 15 Posts
Top