Second Generation Nissan Xterra Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
just got the F-U1000 today and could not start the vehicle. Put in a new battery since I needed one anyway, no start or crank. Grounds are clean. Fuses replaced are in good order, no start or no crank. Now I am wondering if it is the TCM. I've put 170,000 miles on the vehicle after the first doing the coolant bypass mod at 10,000 miles. I do all regular maintenance. Any suggestions? Thoughts? I am going to tow to Nissan later tonight, since I have gone through all of the checklists that other posts have gone through. I need this vehicle up and running since my wife is pregnant and will be our baby shuttle. Thanks in advance.
 

·
Registered
Joined
·
2,228 Posts
If i remember correctly I got that once after overheating the trans. I had it cleared , changed out the fluid and its been fine since.

do you have any symptoms or is the trans still operating correctly?

I never had a no start/ crank issue associated with the u1000.

did you tow something lately or do anything that would have overheated the trans?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #3
I have never towed, I have had high rpm issues where the tranny did not want to shift up to the next gear lately. But I don't think the vehicle's tramsmission overheated. I do drain and fills every 10,000 miles on the transmission fluid. I will try reconnecting the battery and checking fuses in the dashboard one more time. I'm leaning towards the tcm may have an issue, but I never had strawberry milkshake.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #4
just wondering is there a way to reset the TCM?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #7
here's a youtube video that makes me wonder why no crank no start therefore TCM/valvebody.
 

·
Registered
Joined
·
5,066 Posts
Interesting. I guess it would be easy to see if you have a blown fuse. What about the relay swap for the IPDM?
 

·
Premium Member
Joined
·
9,953 Posts
Can't see a TCM not allowing an engine to start.
It happened to me.

Not necessarily the tcm preventing starting but the lack of communication between the ecu and tcm.
 

·
Registered
Joined
·
5,066 Posts
So it just stops the flow of data in the chain? Nissan and their wonky electronics. I had a Maxima that had no fused protection to the ECM. JUmp starting was not a good idea. I had an older Infiniti that was known to be even worse on fused protection for the ECM. IACV, TPS, and the electronic motor mounts would all short the ECM.
 

·
Registered
Joined
·
128 Posts
https://cars-fault.blogspot.com/2017/06/u1000-nissan-can-communication-line_4.html

From that site:

Usually the problem is poor harness ground connection. There is a service bulletin for the following Nissan models with U1000 code: 2005-2006 Nissan Frontier Nissan Xterra 2005-2006 Nissan Pathfinder 2004-2006 Nissan Quest 2003-2006 Nissan 350Z


What causes U1000 code?


Controller Area Network (CAN) communication harness is open or shorted
Faulty Engine Control Module (ECM)
Poor harness ground connection.
U1000 Possible Symptoms
If the U1000 stands alone, no symptoms may be present
Symptoms will likely be present synonymous with the secondary code indicating a particular failure-a failed climate control module or a failed automatic headlight-dimming module for example
In the case of a known Nissan TSB (technical service bulletin), symptoms may include engine stalling, hesitation, lack of power, failure to start or other potential symptoms.
Controller Area Network (CAN) communication harness is open or shorted
Faulty Engine Control Module (ECM)
Poor harness ground connection.
Engine Light ON (or Service Engine Soon Warning Light)
What are the U1000 Possible Causes..?

Controller Area Network (CAN) communication harness is open or shorted
Faulty Engine Control Module (ECM)
Poor harness ground connection.


Best of luck!
 

·
Registered
Joined
·
97 Posts
Discussion Starter #12
So , the update. Nissan is telling me that the transmission pan has a dent on the bottom possibly causing a short in the tcm, they will be dropping the trans oil pan and will checking out the tcm. Im trying to get pricing on this. So far diagnostic cost me $180. I'm thinking that I will be adding another zero to that number if the tcm is bad. if tcm is not bad than total diagonostic plus parts tran oil pan , gasket and oil, will cost me around $600, instead of $1800. Sounds like a rip off in pricing no matter what.
 

·
Premium Member
Joined
·
1,498 Posts
Do you have the old white IPDM or the new black version? It's been the cause of U1000 code problems in 2 cases I've seen. Might not be in your case but it's a lot cheaper than $600.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #14
ipdm tested okay, still have the white version, they changed the relays under recall.

$486.32 for transmission oil pan , gasket, bolts, washer and tranny oil ; also check valve assembly, if bad, price is $1589.13

or

$1589.13 for valve assy, transmission oil pan , gasket, bolts, washer and tranny oil.

difference of $1102.81 …
 

·
Registered
Joined
·
97 Posts
Discussion Starter #16
yea, lesson learned
 

·
Registered
Joined
·
97 Posts
Discussion Starter #17
picked up the rig , and gosh darn it, oil pan was evenly dented. Im picking up a transmission skid on a couple days. Hopefully no more issues. Thanks guys.
 
1 - 17 of 17 Posts
Top