Second Generation Nissan Xterra Forums banner

1 - 9 of 9 Posts

·
on line
Joined
·
2,876 Posts
Discussion Starter #1
Hi! I have a 2007 4x4 S model no mods except for the bug guard, bullbar and some inside stuff.

I went to the beach this week (before i installed bullbar mind you) and noticed a squeaking/creaking sound coming from the suspension, especially the front, when going over hump and bumps even on some pavement with cracks etc. Is this normal? The truck has 16k on it mostly easy driving with some light 4x4 like at the beach..... anyone elses' do the same thing? It sounnds like an old army jeep, which is kinda cool if it's normnal, but just concerned...


thanks..
 

·
on line
Joined
·
331 Posts
try turning the rubber "cushions" on the underside of the hood counter-clockwise. I think that might solve your problem
 

·
on line
Joined
·
2,876 Posts
Discussion Starter #3
really??? i wil ltry!!!

thanks
 

·
on line
Joined
·
15 Posts
I've also been dealing with this creaking and squeeking for about a year now too. I have an 05 OR X with just under 17k miles on it. Its a very subtle squeak that is normally drowned out by my music when cruising around town. However, when I am driving faster than 45mph or so the squeak is no longer there.

Its one of those things thats annoying but doesnt bug me enough to go deal with the dealership.
 

·
on line
Joined
·
264 Posts
mine is kind of a whistling noise is this the same thing your all talking about?
 

·
on line
Joined
·
161 Posts
i have this exact same squeaking creaking thing sound that annoys the heck out of me.... and i first noticed it right after a beach trip as well

ill try the rubber disc thing, but something i did notice that was ALSO squeaking was that the battery bracket had come completely off and was scraping against the underside of my hood... idk how this happened, the nuts weren't lose, its like it had just wiggled its way off some weird way.... i fixed it and that squeak went away but i still have that creaking sound
 
1 - 9 of 9 Posts
Top