Second Generation Nissan Xterra Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1 (Edited)
Hey all, recently I've been noticing two things which may or may not be related.

1. A rattling noise when going over bumps, seeming to come from the engine bay near the front.

2. During idle, especially when in gear, there is a loud clicking that sounds like a solenoid switch followed by 1-2 seconds of rough idle before it calms down. During the rough idle the same or very similar rattling noise comes from the front.

Almost positive this is not the VIAS rattle, much more "clangy", less buzzy, and occurs at idle only.

I'll try to get a video with sound tomorrow.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #5
Sounds like the fan clutch click, so the rattle is probably in the fan shroud, or maybe the skid plate below is a bit loose and the increase air is rattling it.
See I was hoping it was the fan clutch, but the fan appears to be spinning the entire time.
cant hear anything man
Fixed it, had accidentally posted without sound.


Here's a new video from the inside and the sound going over bumps

 

·
Registered
Joined
·
554 Posts
The fan never actually stops, it just goes faster when the clutch engages. I would crawl under and see if there is any play in the lower shroud or the skid plate.
Is the suspension/bump noise the same? cant really tell.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #7
The fan never actually stops, it just goes faster when the clutch engages. I would crawl under and see if there is any play in the lower shroud or the skid plate.
Is the suspension/bump noise the same? cant really tell.
Ah, well today I pulled the entire shroud, it comes loose pretty easily and it a possible that it is just coming loose and rattling. I didn't find any play in the radiator skid or the oil pan skid. I think that the bump noise and engine rattle are the same they are, they have the same clanging sound. I checked my front suspension by flexing both using a jack to see if there was any play on the struts but nothing. Today with my fan shroud out, I checked all the pulleys and nothing seemed out of place. :/
 

·
Registered
Joined
·
107 Posts
It's hard to tell from the videos. The engine click to me sounds like the a/c kicking on. That might explain the couple seconds of rough idle. As for that rattling, I dunno. Compressor bearing maybe???

The rattle over the bumps again it's hard to tell over video. My first guess would be sway bar bushings. You wont get the sway bar to move much manually so it's hard to judge it that way. It is a pretty tell tale sound once you know it though. Could also be worn or loose strut / shock mounts.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #9 (Edited)
Well, the noise from the engine is definitely the A/C clutch great job everyone on figuring that one out. I can literally make the rattling happen if I turn on or off the AC. As for the suspension item it does appear that that's probably different, and isolated. Pinpointing that may be a little bit more tricky. I'll check the sway bar links. To my knowledge the rattling began right after I added my lift and to add the lift on we did loosen the sway bar so that might have been it.
 

·
Registered
Joined
·
107 Posts
It is the sway bar bushings that would make that rattle. They mount the sway bar to the crossmember under the engine. As they wear they can get a little play in them that makes a knocking or rattling over bumps.
 

·
Registered
Joined
·
200 Posts
Discussion Starter #11
It is the sway bar bushings that would make that rattle. They mount the sway bar to the crossmember under the engine. As they wear they can get a little play in them that makes a knocking or rattling over bumps.
I will hunt for this!! I wonder if I forgot to bolt one all the way down after my lift... :eek:
 

·
Registered
Joined
·
200 Posts
Discussion Starter #12
Well I feel sheepish. I had the general location correct, but the cause completely wrong.

Thank you @05RedBrawn6Sp for directing me towards the bushings. Fortunately it was not the bushings, it was in that area though. At some point I must have banged my stock rad skid bending it slightly. This slight bend was causing it to rest ever so slightly against the frame. Additionally, it clearly loosed the skid, allowing it to vibrate. When going over bumps I'm pretty sure the flimsy aluminum was basically just flapping against the frame. Then when the car idles rough due to AC compressor, the skid starts rattling against the frame. I can't be certain this is the only rattle. But after I bent it back down, no more rattle. Can't wait to replace with a full size skid when I get my front bumper!
 

·
Registered
Joined
·
107 Posts
Thank you @05RedBrawn6Sp for directing me towards the bushings.

You're very welcome.

It's funny how coincidences happen. I now have a clunk that I suspect is a sway bar bushing. Haven't had the time yet to really diagnose it. Sometimes it sounds like it's in front and sometimes in the rear. I've done a bunch of suspension work but not those. Hoping I didnt miss something and have a loose part somewhere.
 
1 - 13 of 13 Posts
Top