Second Generation Nissan Xterra Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
So, I make my 2.5 hour drive from W. OK to the TX panhandle & stop for luch in town with a friend. My rig about 10 miles or so out of town. As I'm coming to the little town (a grain elevator, a cafe/quick top, & 5 houses) that the rig by; my gauges cut out. I thought the entire truck died. I slip it into neutral, turn the key to OFF, return to ON, everything comes back on, restart the engine, slide back into 6th, & keep on trucking the last 3 miles. I'm wonder WTF just happened & it does it again. The engine & radio were still going. Now, I have a BRAKE & BATTERY dash light on. So, alternator, battery, or connection. OK. I call a parts store that can have an alt Tuesaday morning. No biggy, I'll get it checked out in a bit. Got caught up with rigging up & it's dark. I'll wait until daylight. So, I'm having a smoke in the driver's seat with the door open, empty ignition switch, & dome lights off (skeeters & junebugs suck right now), and the dash lights/odometer flashed on for a second. Shortly after, we got a thunderstorm & soggy caliche. Gonna wait to crawl under the X until it dries a little. Has this happened to anyone else? Should I still be looking at the alternator & battery or something else?

Also, I have an oil leak from the passenger side timing cover after having my timing chain replaced. The oil is leaking onto the alt, made me think that may have caused it to go out.
 

·
Registered
Joined
·
595 Posts
Have the battery tested.

Check ALL cables and grounds. Clean the contacts, especially the POS and NEG cables at the battery.

Then go the alternator route.

My two pennies leans to either a bad battery or connection at the posts.
After that is ruled out it can get complicated.

Your leak onto the ALT is definitely no bueno though, and could have fried it.
But it’s rare. I’ve seen oil soaked alternators that have lived forever.
Alas, it’s mechanical....so anything is possible.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #3
Have the battery tested.

Check ALL cables and grounds. Clean the contacts, especially the POS and NEG cables at the battery.

Then go the alternator route.

My two pennies leans to either a bad battery or connection at the posts.
After that is ruled out it can get complicated.

Your leak onto the ALT is definitely no bueno though, and could have fried it.
But it’s rare. I’ve seen oil soaked alternators that have lived forever.
Alas, it’s mechanical....so anything is possible.
Thanks. That's my plan. It's the dash coming out randomly that confuses me. I just discovered the leak & I gotta get it back to the dealership to have it warrantied. I'm going to have both tested before laying down any money.
 

·
Registered
Joined
·
595 Posts
Odd behavior is indicative of poor electrical flow. Years ago my Rover was shifting badly. I sh!t a brick, calmed down and did some research, and wouldn’t ya know it? Bad battery.


Force the dealer to replace the alternator, as their shoddy work caused the leak onto it. Push the issue. They should be on the hook for that. Not you.
Press them HARD. Say no way to cleaning it either. Get the serial # so you know for sure it’s a new one.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #5
Odd behavior is indicative of poor electrical flow. Years ago my Rover was shifting badly. I sh!t a brick, calmed down and did some research, and wouldn’t ya know it? Bad battery.


Force the dealer to replace the alternator, as their shoddy work caused the leak onto it. Push the issue. They should be on the hook for that. Not you.
Press them HARD. Say no way to cleaning it either. Get the serial # so you know for sure it’s a new one.
A buddy of mine works the service desk at the dealership, so I'm not expecting any guff; but I am prepared to force it, if need be. I just discovered the leak the other day, and I thought I could hold off until I got back home for more than just a couple days. I'm 150 miles from the nearest Nissan dealership & it's the one back home. :|
 

·
Registered
Joined
·
214 Posts
Check that the battery terminals can be tightened properly. After tightening, you should not be able to rotate the terminal with your fingers.

The one on the positive terminal of my 2006 is made from pressed copper sheet, not solid metal like the one on the negative terminal. After replacing my battery last November, I had a hard time tightening the positive terminal. After removing all the crusty stuff from the battery, I noticed that the copper terminal had corroded so badly that the little copper left was stretching as I tightened the bolt. A replacement terminal from the dealership was less than $10.

I guess you are doing oilfield work?
 

·
Registered
Joined
·
155 Posts
Discussion Starter #7
Check that the battery terminals can be tightened properly. After tightening, you should not be able to rotate the terminal with your fingers.

The one on the positive terminal of my 2006 is made from pressed copper sheet, not solid metal like the one on the negative terminal. After replacing my battery last November, I had a hard time tightening the positive terminal. After removing all the crusty stuff from the battery, I noticed that the copper terminal had corroded so badly that the little copper left was stretching as I tightened the bolt. A replacement terminal from the dealership was less than $10.

I guess you are doing oilfield work?
Yes, I am oilfield. :rockin:

Between work & rain out here, I just now (10 minutes ago) had a chance to look at the battery terminals. They both have the felt pads & corrosion in very, very minor/spotty on the outside. The negative has been replaced with a clamp-on lead piece. Everything was tight & no interior corrosion. I have a multimeter & the resting battery had 12.4v at the terminals after sitting since Saturday. I started it up & was getting 11.4v & dropping slowly at the terminals. I do believe, so far, that it's the ALT. Location is WAAAAYYYY too muddy to climb under my truck right now to take it off & have it tested.

Called the dealership and was told I had to bring it in for them to look at it. I'm 138 miles away on a job. It's gonna be 10-20 days before I'm home. This
 

·
Registered
Joined
·
214 Posts
Yes, I am oilfield. :rockin:

Between work & rain out here, I just now (10 minutes ago) had a chance to look at the battery terminals. They both have the felt pads & corrosion in very, very minor/spotty on the outside. The negative has been replaced with a clamp-on lead piece. Everything was tight & no interior corrosion. I have a multimeter & the resting battery had 12.4v at the terminals after sitting since Saturday. I started it up & was getting 11.4v & dropping slowly at the terminals. I do believe, so far, that it's the ALT. Location is WAAAAYYYY too muddy to climb under my truck right now to take it off & have it tested.

Called the dealership and was told I had to bring it in for them to look at it. I'm 138 miles away on a job. It's gonna be 10-20 days before I'm home. This
Cool! I started working on downhole tools 2 1/2 years ago.

I hope you make it to the dealership without problems. It would be a long tow otherwise.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #9
Cool! I started working on downhole tools 2 1/2 years ago.

I hope you make it to the dealership without problems. It would be a long tow otherwise.

Awesome! I'm a mud logger, but I've also roughnecked, roustabouted, & heavy lift before my 30s.

Thank ya. I do too. I had the battery tested this morning. Came back good. Now, I'm preparing my plan of attack to get the dealership to tow it in & try for a loner truck.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #10
Quick update: I called the dealership and they're trying to pass off the oil leak like it had one before they worked on it. My dad went to talk to them in person for me, since I'm so far away. They tried to brush him off with the same story. Didn't work. They told him to have me take my X to any dealership to verify that it is leaking oil from the timing chain cover. There's only a Chevy house here, but I dropped it off yesterday & they're gonna check it out for me. This dealership is not sitting well with me. Where I'm from, if your service department isn't amazing, your dealership won't be successful.
 
1 - 10 of 10 Posts
Top