Second Generation Nissan Xterra Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

New to the forums. This is the first time I've done much to my Xterra so I've just discovered the forums.

I just installed a Sony head unit in my 05 Xterra. I had the RF stock system with steering wheel controls. I am now working on the Axxess. I have tried following the instructions on the Axxess site for my vehicle. It directs me to pin 10 and pin 1 of the vehicle harness. The install book lists the same pins but describes the wires as red and grey. Pin 1 in my vehicle is green. Once it is all hooked up and I run the auto-detection, the ASWC doesn't recognize whatever wire is attached to pin 1 (the green wire). If I swap wires, the ASWC will again detect the wire connected to the grey wire and not detect anything connected to the green wire.

I am stumped. I tried taking everything out and starting over. I tried every combination of wire to wire. Interestingly, if I only connect one of the wires from the ASWC to the grey wire and run the auto detection, it sees the single wire but completes the program. Once I hook up the second wire and re-run the program, it still sees one wire but can not complete the program.

I suspect I am tapping in to the wrong wires.

I came across the diagram on this page:

http://www.justanswer.com/car-electronics/4etm6-hi-2005-nissan-frontier-crew-cab-w-rockford-fosgate.html

It is same year but the frontier. I believe the frontier and xterra for that year were the same. This diagram is straight forward but none of my harnesses have that many wires. At least the colors on that diagram match what the instructions say they should be!

Any help would be greatly appreciated. I've installed car stereos before but never dealt with steering wheel controls. Thanks for the help.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
As I went to bed last night, it dawned on me that I believe the 4th wire harness that was plugged in to my OEM stereo might be the steering wheel controls. I remember reading somewhere that the ASWC instructions treat all the harnesses as one big one. I originally figured the two unused harnesses were from the Sirius tuner. Now I believe one is for the steering wheel controls. Once it's light out, I will go test this theory. Thanks for reading!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
My hunch was correct. As soon as I dug in to it this morning, I immediately saw the three wires mentioned in the install book. They were all the colors they were supposed to be. It explains why I was scratching my head last night trying to figure out what didn't make sense. The ASWC works like a champ now.

Now I am on to installing the same head unit in my wife's car. Hope hers goes easier than this one!
 

·
Registered
Joined
·
1 Posts
I realize this thread is old but I'm just now having a similar issue regarding my 05 Xterra. IT had a RF stereo and I'm installing a Pioneer. I just don't know which wires I'm supposed to tap for these SW controls to work. I'm fairly certain it would be to the connector in the attached picture that only has 3 wires. They are not the same colors or pin locations as described in anything I have already read. Which wire do I connect the White Green to and which does the Grey Red go to? Any help would be truly appreciated.
 

Attachments

·
Some random dude
Joined
·
361 Posts
I realize this thread is old but I'm just now having a similar issue regarding my 05 Xterra. IT had a RF stereo and I'm installing a Pioneer. I just don't know which wires I'm supposed to tap for these SW controls to work. I'm fairly certain it would be to the connector in the attached picture that only has 3 wires. They are not the same colors or pin locations as described in anything I have already read. Which wire do I connect the White Green to and which does the Grey Red go to? Any help would be truly appreciated.
According to the ASWC-1 instructions, the red/grey wire on the harness goes to red/grey on the aswx, the blue goes to ground, and the grey goes to the white/green
 

·
Registered
Joined
·
1 Posts
My hunch was correct. As soon as I dug in to it this morning, I immediately saw the three wires mentioned in the install book. They were all the colors they were supposed to be. It explains why I was scratching my head last night trying to figure out what didn't make sense. The ASWC works like a champ now.

Now I am on to installing the same head unit in my wife's car. Hope hers goes easier than this one!
Hey I'm installing the the steering wheel controls in a 2010 Xterra. Can you help me out with what wires you tapped into?
 
1 - 8 of 8 Posts
Top