Second Generation Nissan Xterra Forums banner

81 - 100 of 112 Posts

·
Registered
Joined
·
45 Posts

Attachments

·
Registered
Joined
·
20 Posts
Scrabo, Thanks again, SO much! This worked flawlessly for me today. Took me from D207 to D407 for my 2015 Pro4X.

For those wanting a visual guide to what the process will look like, here's a link to a TSB for the same procedure, but for a different software version. Except for the software version numbers, everything looked exactly the same for me as I proceeded.

https://www.nissan-techinfo.com/asistgc_1/CAENG/diskdocs/1/V/H/1VH39.PDF

And for those who were wondering (I was). I used an 8gig usb formatted to FAT32. The download itself unzipped to just over 7gigs.


Thanks again!!


t
 

·
Registered
Joined
·
64 Posts
^...

Exactly. I'm curious if there's any significant differences in software & firmware between a '15 P4X Xterra w/ Nav Unit and a '19 P4X/SL Frontier w/ Nav Unit.

Don't know if the "F" prefixed ver would work on ours or not...


BTW, MNY THX to SCRABO for the D407 link. Works like a charm and saves some ca$h from the Dealerships.
 

·
Registered
Joined
·
470 Posts
Thanks! :)

Wow, I just found that I have the old D025!
I will look into doing this update myself. Curious to know what version I have in my 15 PRO 4X.
 

·
Registered
Joined
·
20 Posts
I've had a wonky volume control since before (and now after) the update. Before the update I pulled the volume knob off and sprayed a little contact cleaner in as best I could and rotated it, the volume control worked immediately and perfectly after that. Then, after the update, it got really cold out and the volume control is now random again "sometimes". Of course with the radio mounted in the dash, I couldn't really get much cleaner to go where it needed to. When the weather gets warmer, I'll go out and pull the radio so I can hold it vertically. Hopefully that will allow the contact cleaner to really flow into the volume pot and thoroughly clean it up for a longer lasting fix.

I did the update because I've experienced random rebooting of the system while driving. I think (for my system at least) the volume knob quirkiness is a mechanical issue and not related to the system software.
 

·
Registered
Joined
·
368 Posts
I've had a wonky volume control since before (and now after) the update. Before the update I pulled the volume knob off and sprayed a little contact cleaner in as best I could and rotated it, the volume control worked immediately and perfectly after that. Then, after the update, it got really cold out and the volume control is now random again "sometimes". Of course with the radio mounted in the dash, I couldn't really get much cleaner to go where it needed to. When the weather gets warmer, I'll go out and pull the radio so I can hold it vertically. Hopefully that will allow the contact cleaner to really flow into the volume pot and thoroughly clean it up for a longer lasting fix.

I did the update because I've experienced random rebooting of the system while driving. I think (for my system at least) the volume knob quirkiness is a mechanical issue and not related to the system software.
Thanks for the information. It hasn't bugged me enough yet. I just use the steering wheel controls.
 

·
Registered
Joined
·
470 Posts
I can zip up the thumb drive and put it somewhere you can ftp it from, it’s about 3.6gb zipped



Takes approx 40 mins, you can’t do anything while it’s running, it tells you when to remove the thumb drive and then it does a few restarts



For the IT nerds out there, it’s based on Linux



ntb15-011 Is the SB to ask about


Any chance I can do this as well? I’ve been having problems using my iPhone in my 15 PRO -4X while using i Tunes and other music play aps. It would disconnect bluetooth itself at random times and say no audio files found or it would show what version iphones OS it supports etc... drives me crazy.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
I got the v10 (25920 9HT0B) maps working as well with the d407 firmware. Had to restart the x a few times with the new maps in to get it to update software. Before that it would not work and said to purchase nissan maps. The d407 firmware took about 45 minutes. Map software updated twice and took about 10 minutes.
 

·
Registered
Joined
·
6 Posts
Any chance I can do this as well? I’ve been having problems using my iPhone in my 15 PRO -4X while using i Tunes and other music play aps. It would disconnect bluetooth itself at random times and say no audio files found or it would show what version iphones OS it supports etc... drives me crazy.


Sent from my iPhone using Tapatalk
Use info earlier in this thread to check what version you have. Probably d207 which other 2015 people have. This means you can update to d407 using the info and download link in the thread; really anyone prior to d407 can update I assume. Just go for a 45 minute drive so there is no chance the vehicle shuts off during the update. Will it solve your issue? No idea... but probably won't make it worse.
 

·
Registered
Joined
·
2 Posts
Thank you so much! Updated from B155 to D407 successfully.
I had an issue before where I would try to pick a song inside a folder, it would always play the first one in that same folder no matter what. That bug appears to be gone.
 

·
Registered
Joined
·
3 Posts
Hi all, stumbled on this thread while looking for a firmware updates for the HU.
I have gone through the thread and haven't managed to find a suitable updated for my HU. The Software version i have is A101 and Hardware 019. I have checked with Nissan here and they say there is no update available.
The Car is a 2014 X Offroad trim.
Any suggestions on how to find an update?

Xterra.jpg
 

·
on line
Joined
·
117 Posts
Even after re-flashing the the HU with the link I previously provided, it will still have issues, my latest if it is too hot (AZ after all !!) it either doesn't start at all, or comes back for a minute and off again. I recently had it working enough for me to get in and reset it to factory settings... day 4 and so far so good. I was about to replace it with an Alpine ILX-W650 , but obviously the HU decided to play nice rather that be replaced by a younger, sexier unit. :)
 

·
Registered
Joined
·
2 Posts
Scrabo, Thanks again, SO much! This worked flawlessly for me today. Took me from D207 to D407 for my 2015 Pro4X.

For those wanting a visual guide to what the process will look like, here's a link to a TSB for the same procedure, but for a different software version. Except for the software version numbers, everything looked exactly the same for me as I proceeded.



And for those who were wondering (I was). I used an 8gig usb formatted to FAT32. The download itself unzipped to just over 7gigs.


Thanks again!!


t
Hey everyone, I downloaded the file, have my usb drive formatted FAT32, copied the file straight over(3.5GB) and the system does not find the update. Current SW is A040 and HW is 031. Any advice on where I am going wrong?
 

·
NewX’er 4life
Joined
·
2,516 Posts
If you have the listed build software that can be upgraded, download it and unzip. If you leave all the contents in the folder and drag that over to a USB drive the system won't recognize it. I had the same issue. I dragged the items inside the folder to the USB drive directly and it worked. I then followed the linked service bulletin steps, fairly straight forward. If you don't have the listed software, none of this matters, you'll have to figure out if your software even has an update available.

 
81 - 100 of 112 Posts
Top