Second Generation Nissan Xterra Forums banner

1 - 16 of 16 Posts

·
on line
Joined
·
83 Posts
Discussion Starter #1
I just hit the 15000 mile mark, and just now I'm starting to hear an odd sound from the engine compartment. Upon cold start through roughly the next 10 minutes there is squeaking coming from the or within the proximity of the alternator. Anyone experience this before? Also, would you have an idea why this would happen, or how to fix it?
 

·
on line
Joined
·
844 Posts
spray a little WD40 right into the alternator, usually a half to two thirds of a can will be enough.







(kidding)
 

·
on line
Joined
·
3,217 Posts
If it happens for that amount of time then it's the belt tensioner that needs to be replaced. There is a TSB (tech service bulletin) for that. You'll have to take it in to the dealer. They should replace it for free and give ya a new belt as well.
 

·
on line
Joined
·
83 Posts
Discussion Starter #6
Thanks for reminding me to check the TSB. Would you be referring to the TSB for the squeaky fuel pump? This was the only TSB I found that mentioned a squeak.
 

·
on line
Joined
·
3,484 Posts
http://www.nissanhelp.com/Bulletins/Xterra/2005/1.htm

You will find them all above link. Dan is right that is most likely your problem, hold on the WD40 if you get it on anything it's call foreign contamination and will make a lot of stuff squeak up there, it could also get on the pulley's and contaminate the new belt and make it squeak. Most time Just a new belt will work, dealer decides. New belt only cured mine 12K miles ago. Now at 25K MC
 

·
on line
Joined
·
1,891 Posts
Thanks will do, I've got to go down to the dealer anyways to ge my oil changed out and get the car looked at, my steering column is creaking like crazy, even worse now that is is getting colder here in NC.
 

·
on line
Joined
·
83 Posts
Discussion Starter #11
I just got back from the dealer; made an appointment for tomorrow to have it looked at. Will let you know what happens.
 

·
on line
Joined
·
83 Posts
Discussion Starter #14
I'm a Network Field Engineer for my neighboring town's school disctrict. I'm always out and about doing my job during the day, but found time to stop at the dealer for what's important; keeping my X running.
 

·
on line
Joined
·
83 Posts
Discussion Starter #15
Dealer replaced the belt-tensioner under recall, and charged no labor since X was under warranty. I printed out the TSB for this, and made it sure they had a copy when I went for appointment.
 

·
on line
Joined
·
1,361 Posts
i just got a squeak as well, but I am only at 1800 miles, it shouldn't happen this early should it?
 
1 - 16 of 16 Posts
Top