Second Generation Nissan Xterra Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just purchased a very beautiful 2009 Nissan Xterra SE 4x4 with 185,000 Miles.
I have no way of tracking down the service history of this truck so where should I start to get the truck in proper maintenance check.

Thanks!
 

·
Registered
2012 Nissan Xterra S
Joined
·
423 Posts
The radiator and transmission fluid. Check for any signs of SMOD and check the radiator. There's a thread on here about serial numbers of bad radiators. You'll want to make sure yours has been replaced or bypassed at the very least. Search for SMOD too if you don't know what that is. Tranny costs ~5k installed so don't wait on this. New radiator is ~150 bucks. *Assuming Auto Transmission

Next item is timing belt tensioners for that year iirc. When they start making noise they will need to be replaced. At that mileage both of these things may have been done already.

The only other issue with these is the evap canister. That'll typically throw a code. Otherwise, all fluids should be checked/changed and check the spark plugs. If the vehicle is in really nice condition all of these things might have been addressed and you'll have nothing to worry about.

Sent from my Pixel 4a using Tapatalk
 
  • Like
Reactions: orlandogil14

·
Registered
Joined
·
2,753 Posts
I just purchased a very beautiful 2009 Nissan Xterra SE 4x4 with 185,000 Miles.
I have no way of tracking down the service history of this truck so where should I start to get the truck in proper maintenance check.

Thanks!
There isn't much at that mileage that probably couldn't use replacement really. As far as importance if it's an auto I'd replace the radiator first, also check the plastic fittings going in/out of the heater core (passenger side upper firewall area) as they disintegrate over time and like to break off at the worst time. After that do the rear diff breather mod, fluids, filters, and plugs. Most everything else depends on whether or not you notice issues while driving or something is leaking.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thank you for your input.

I opened the radiator cap and it has this gunk attached to it, it also has some little spots inside the radiator. What is this?
I changed the engine oil but it looked normal, I will check the transmission fluid this afternoon.
The transmission is not vibrating or slipping but is not taking 1st gear, it shifts flawlessly, 4x4 is working correctly.
 

Attachments

·
Registered
Joined
·
2,753 Posts
Thank you for your input.

I opened the radiator cap and it has this gunk attached to it, it also has some little spots inside the radiator. What is this?
I changed the engine oil but it looked normal, I will check the transmission fluid this afternoon.
The transmission is not vibrating or slipping but is not taking 1st gear, it shifts flawlessly, 4x4 is working correctly.

That gunk isn't a great sign, the inside of the cap should definitely be clean. Calsonic is the original brand of radiator that had the trans cooler leak problem in the earlier models but it sometimes happens in later years too. It's pretty common that when someone or a used lot notices the problem they flush the fluid and sell it quickly to pass off on the next guy. You should probably replace the radiator and do the poor mans flush on the transmission, it's possible you caught it early enough to stop any major damage.

When you say it won't take 1st do you mean when you try to manually shift it to 1st it won't engage? That's usually caused by the switch in the gear selector assembly, there's a small pin in there that can get dislodged.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thank you!, I will replace the radiator and flush the transmission fluid asap.
When I manually try to engage 1st it stays at 2nd, it doesn’t show it’s on 1st gear on the screen, I tried at a complete stop, nothing blinks or makes any mechanical movement, it just doesn’t shift. How would you address this?
 

·
Registered
Joined
·
2,753 Posts
Thank you!, I will replace the radiator and flush the transmission fluid asap.
When I manually try to engage 1st it stays at 2nd, it doesn’t show it’s on 1st gear on the screen, I tried at a complete stop, nothing blinks or makes any mechanical movement, it just doesn’t shift. How would you address this?
Mine does the same, I only know about the pin because I messed mine up when I was modding the backlighting on my shifter. You can buy the complete assembly from junk yards but you can access the pin by removing the plate with the gears listed on it. The large plastic part on top of the center console comes off pretty easily, if I remember correctly you can just pry it up and rotate it out of the way without removing the shift knob. Once that's out of the way you'll see the plastic clips holding the gear number thing on. Be careful with that one though, it's extremely brittle and can crack easily. With that off you can see the pin, I'd check to see that it hasn't just fall off.
 

·
Registered
2012 Nissan Xterra S
Joined
·
423 Posts
I certainly hope this isn't a SMOD flip some pos dumped on you.

Sent from my Pixel 4a using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Thanks man, I also hope not but I will take all possible precautions moving forward. I’m sure everything will work out just fine, there seems to be plenty of information on this forum to help me get this truck working 100%.
 

·
Registered
Joined
·
16 Posts
I put 265K on my first Xterra (2000) and still ran great. When I did a compression check, just before getting rid of it, the difference was 100ths from factory. I tore up everything else on it, but they last forever. I now have a 2009 and a 2015. Need to write Nissan to bring it back as rumored
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
I put 265K on my first Xterra (2000) and still ran great. When I did a compression check, just before getting rid of it, the difference was 100ths from factory. I tore up everything else on it, but they last forever. I now have a 2009 and a 2015. Need to write Nissan to bring it back as rumored
Thats good to know! Thank you. I also hope they bring them back. :)
 

·
Registered
Joined
·
56 Posts
Thats good to know! Thank you. I also hope they bring them back. :)
They haven't even replaced the Frontier. I'd hope they will make another X on the new platform but they are probably also watching the development of the next 4runner, as well as watching the Bronco... As it sits (as a person who wants a manual with a locker(s) and a 5k tow capacity) I hope they do something sooner than later.
 
1 - 12 of 12 Posts
Top