Second Generation Nissan Xterra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
501 Posts
Discussion Starter #1 (Edited)
My 05 X was taken into the shop a few weeks ago to have the heater core replaced. As we all know - the entire dash has to come out. Well since everything was put back and I have been driving it around for a week or two - the AC control unit inside the car has started to act funky. The AC lights would blink and if I move the controls or push the buttons - the AC would then go on and off intermittently. As of now - the AC is blowing but no cold air.

I took it back to the shop and they inspected the compressor and the refrigerant, however checked out fine. Fuses were inspected as well and no issues there. They now believe it could be an electrical problem and to my thinking - too much of a coincidence. I'm guessing some wires got pinched in the back of the control unit and hope they fix it at no charge.

What are some of your thoughts/opinions?
 

·
on line
Joined
·
267 Posts
Does the compressor turn on when you select AC and turn the system on? You should be able to hear the magnetic clutch engage.
 

·
Registered
Joined
·
2,187 Posts
They unplugged something or pinched wire while disassembling . Go back and get them to fix it unless they can prove it is an underhood issue and not the control panel

My 05 X was taken into the shop a few weeks ago to have the heater core replaced. As we all know - the entire dash has to come out. Well since everything was put back and I have been driving it around for a week or two - the AC control unit inside the car has started to act funky. The AC lights would blink and if I move the controls or push the buttons - the AC would then go on and off intermittently. As of now - the AC is blowing but no cold air.

I took it back to the shop and they inspected the compressor and the refrigerant, however checked out fine. Fuses were inspected as well and no issues there. They now believe it could be an electrical problem and to my thinking - too much of a coincidence. I'm guessing some wires got pinched in the back of the control unit and hope they fix it at no charge.

What are some of your thoughts/opinions?
 

·
Registered
Joined
·
501 Posts
Discussion Starter #5
Does the compressor turn on when you select AC and turn the system on? You should be able to hear the magnetic clutch engage.
The compressor will not turn on when I turn the Fan Speed Knob to Level 1. Then when I select Level 2 - cold air comes on for a few secs then starts blowing warm air. If I select Level 3 or 4 for fan speed - then lights go off for AC and circulation buttons in which it blows nothing but warm or outside air into the truck.

Just yesterday when driving with AC on - both the AC and Circulation button were blinking lights. Something is definitely wrong.
 

·
Registered
Joined
·
501 Posts
Discussion Starter #6
Just got my truck back from the shop. They found the problem to be the blower motor resistor. They replaced it and $109 dollars later - all is fine.
 
1 - 6 of 6 Posts
Top