Second Generation Nissan Xterra Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Teaching my oldest son to drive the other night and he went over a small curb with the right front tire. Didn't think anything of it until the next morning when I went to drive to work and got the dreaded ABS BRAKE VDC and SLIP lights on all at once when I went over 15mph.

Over the weekend I took the ABS sensor off the right front wheel and cleaned it, think maybe it had come loose or that possibly my wheel hub assembly was going out and causing the lights to come on. Unfortunately, that did not resolve the light situation.

So, my current codes are C1163 and C1140.

C1163 Steering Angle Sensor
C1140 Actuator Relay

Should I start by getting an alignment to see if that clears the codes? The vehicle seems to drive straight enough but I can see from some research that the steering angle sensor can be fairly sensitive. The Xterra drives and brakes just fine at the moment, but this will be his vehicle in January when he turns 16 and I don't want him driving with any warning lights on.

Any help or feedback would be appreciated.
 

·
Registered
Joined
·
258 Posts
Try resetting the ABS system with a scan tool? I know Oreilys scan tools have an abs option their menus to scan and tell if any particular sensors may be affecting them t too and can reset it. See if it comes back or could try disconnecting battery for about 10min to reset it also. The steering angle you can reset after battery connected back up by centering your wheel on a road turn off truck then turn back on and drive straight for so many feet and it should reset
 

·
Registered
Joined
·
57 Posts
Discussion Starter · #3 ·
Had the Xterra aligned but that didn't resolve the issue so it looks like I'll be making a stop at the dealership soon to get this issue resolved.
 
1 - 3 of 3 Posts
Top