Second Generation Nissan Xterra Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
First of all I got the DDM Tuning 9007 Hi/Low HID kit. I have used many of their kits with good luck in the past. This one however was a pain, I had to modify the bulb bases a bit to get them to fit right. However my issue is after getting them all wired up I have no high beams, they only do low beam. I tried switching the two power wires and no change and I checked the fuses and they are fine. Anyone else have this problem?
 

·
on line
Joined
·
3,457 Posts
First of all I got the DDM Tuning 9007 Hi/Low HID kit. I have used many of their kits with good luck in the past. This one however was a pain, I had to modify the bulb bases a bit to get them to fit right. However my issue is after getting them all wired up I have no high beams, they only do low beam. I tried switching the two power wires and no change and I checked the fuses and they are fine. Anyone else have this problem?
You have the wires mixed up. I had to play with 3 wires to see which was which to activate the high beams. I don't remember which was which but I had to play with three wires to find the correct slots for each wire to activate them.

Assuming you have a relay harness though, that is.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
The Hi/Low harness has a relay/igniter box on it to switch the Hi/Lo. I have three wires and could only figure out that the white must be ground because if I hooked the white in either power it would blow the low beam fuse.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
Now I have another issue. Got all the wiring sorted out and they worked great last night, but this morning I leave and only my drivers hi beam works now. Not sure if it is a ballast or bulb problem. lows work great and drivers hi is fine but passenger hi does nothing. I am about fed up with these damn things already.
 

·
Registered
Joined
·
1,148 Posts
DDMs wiring harnesses blow.
I went through two of them before i removed my HIDs. I'll be upgrading my harness before reinstalling.

Double check all of your connections before proceeding.
-chris
 

·
Premium Member
Joined
·
9,791 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #13 ·
I have the new slim ballast kit. I had always had the old style raptor kits prior, but I have one of these slim kits in my Triumph motorcycle and it works great. I am going to swap ballasts around next warm day and see what the issue is.
 
1 - 13 of 13 Posts
Top