Second Generation Nissan Xterra Forums banner

1 - 20 of 122 Posts

·
on line
Joined
·
3,754 Posts
Discussion Starter #1 (Edited)
Username: 08XOR

Make: Nissan
Year: 2008
Model: Xterra
Trim: Off Road
Color: Super Black

MODS

Suspension/driveline:

Exterior:
Interior:
Electrical:


so day 1 of install went ok. got the stock bumper and grille off. tow hook off. fog lights mounted in new bumper.


hoisting it up ready to bolt up


heres some better pictures


testing out my new and improved approach angle on a snow bank in my front yard


got my master switch all wired up and mounted



a little torn apart



finally installed my sureelectronics thermometer.



New Tires



as it sits today:

There's more done than I have listed. I'll try to update more as I get time.
 

Attachments

·
on line
Joined
·
4,576 Posts
looks good.....was the red top old? seems like it should last a little longer even if you got it right when you got the truck...
 

·
on line
Joined
·
3,754 Posts
Discussion Starter #3
Thanks man. The battery is old. I wanna say its over 7 years old. This is the third vehicle I've had it in.
Posted via Mobile Device
 

·
on line
Joined
·
3,754 Posts
Discussion Starter #4
updated first post with some pics of my install. would have done more but it was pretty cold today. and i noticed the skid plate mount was not powder coated so i primed it. gonna paint it tomorrow. need to figure out where to mount 4 ballasts for HIDs. any suggestions?
 

·
Registered
Joined
·
1,735 Posts
lemme know how the spacers ride with the shrock and winch. I am hitting a snag myself after ordering and may have to delay my suspension upgrade, but bumpers are otw.
 

·
on line
Joined
·
3,754 Posts
Discussion Starter #7
so i took it for a ride tonight and it does feel a little different but nothing bad. it steers a little harder so i may add some air to my front tires. other than that it rides fine.
 

·
on line
Joined
·
3,754 Posts
Discussion Starter #9
thanks man! i read about that mounting location on here somewhere. just gotta get the 175 lb struts for the hatch now. i can see them fading fast with the added weight on there. no wasnt me man.
 

·
on line
Joined
·
6,064 Posts
Gotchya, yeah I did that on mine a while back, added a tow strap underneath as well. It's a perfect fit! Just be a little careful closing the hatch sometimes that plastic panel likes to unclip it self in some areas.
 

·
on line
Joined
·
3,754 Posts
Discussion Starter #11
ill keep that in mind. i close it real easy tho. i accidentally let it go when closing it the other day and it SLAMMED shut. wont do that again
 

·
Registered
Joined
·
2,222 Posts
LOOKS AWESOME!!! I have to admit the Shrock's are growing on me a bit. I had nearly the same bike but in yellow/silver/black. Sweet rig.
 

·
on line
Joined
·
3,754 Posts
Discussion Starter #15
i did clock it. actually had to do it twice as the first time i did it i went too far. did it at like 10:30 the other night. so the next day i go to put the winch in and realized i clocked it too much. had to take it apart again and go back a little. i was really surprised how easy it was.
 

·
on line
Joined
·
3,754 Posts
Discussion Starter #17
thats good to hear. i may get to test mine out in a couple weeks helping my dad cutting some trees down. haha. he wants me to try and keep them from falling in the swamp. we've done it before with the tahoe my mom had but we'll see how it goes. if we do use my truck ill be sure to get some pics.
 

·
on line
Joined
·
16,147 Posts
nice! i can't believe that hoop held all that up! nice work and looks good. I hope you have better luck with your recon than I did.
 

·
on line
Joined
·
2,306 Posts
Nice truck, and nice bike! I had the SAME one, same color - but sold it 2 years ago... :(
 
1 - 20 of 122 Posts
Top