Second Generation Nissan Xterra Forums banner

1 - 8 of 8 Posts

·
Registered
2011 nissan xterra x
Joined
·
5 Posts
Discussion Starter #1
I have an 11’ xterra x with 171000 miles. Just bought it and almost immediately it started to act up. Obvious misfire at higher speeds. Vibrates really bad on hwy. ran codes and started by doing a tune up. Changed all plugs and all coils. Changed valve cover gasket. Took my propane torch all around the hoses and i didnt find and vacuum leaks. Took it out for a drive to the store and when i got back in it at the store it wouldnt start. Waited for a while and got it to start and drove home. I then tested the fuel pressure with the kit test and tested normal. Since then it starts every time however continues to misfire. Im out of ideas here. Help!
 

·
Registered
2011 PRO-4X
Joined
·
461 Posts
You are getting codes for the crank position sensor P0335 and P0300 engine misfire.
The crank code is almost always a crank position sensor and very common. It is a really good idea and common practice here to replace the crank position sensor and both cam sensor especially with your symptoms. only use OEM sensors or teh Hitachi from Rock Auto as Hitachi is the oem supplier and they are about $45 each on Rock Auto.
 

·
Registered
Joined
·
1,819 Posts
Possible fuel injector I suppose. Did you try running a compression test on cylinder 6 - could be a bad valve as well.

Please post how you did a fuel pressure test. Others in the past have wanted to, but there is no port to do so hence I am interested in your work around?
 

·
Registered
2011 nissan xterra x
Joined
·
5 Posts
Discussion Starter #7
So it ended up being a blown head gasket. Is it worth replacing or should i look for a used motor?
 

·
Registered
Joined
·
488 Posts
Head gaskets are relatively cheap like any other gasket. The cost is in the labor but shouldn’t be too bad time wise.
 
1 - 8 of 8 Posts
Top