Second Generation Nissan Xterra Forums banner

engine

  1. General Xterra
    Hey everyone, I have an 06 Xterra OR 6spd with 226,000KM. It suddenly has an oil pressure issue, which I'm guessing is the sensor but another issue has occurred at the same time. It get these occasional ticks under the hood on and off. It happens on acceleration through 1, 2, 3, 4 but it's...
  2. Powertrain & Driveline
    Hi All, I purchased a 2013 Pro-4X 5AT last fall after being without a vehicle for some time. I had a first gen X in high school when I was younger, and was drawn back to the XTerra now as an adult. My 2013 has about 87k miles on it now (put about 4k on since purchasing it) and I recently had to...
  3. Powertrain & Driveline
    Hey all, new to the forum and somewhat new to Xterra ownership. I’ve got an issue that has gone undiagnosed or unresolved at least from myself, my competent private mechanic, a couple of exhaust shops and of course the local stealership. I’ve got plenty of details to add if your kind enough to...
  4. Powertrain & Driveline
    Hey all, So my 2008 with 92k miles has been giving me problems within the last few days. 3 days ago she wouldn't start. Enging was turning over as normal but it wouldn't ignite. Pumping the gas pedal didn't help. After 2 5s attempts, she finally ignited on the 3rd and ran like normal...
  5. Powertrain & Driveline
    Hello, any suggestions on what’s causing this noise from the front driver area? First encountered it a year ago after parking unevenly in the alley, it used be a barely audible slow tick, went away for a year until recently, parked unevenly on crusty hardened mud for a few hours and the noise is...
  6. Powertrain & Driveline
    Hey everyone, So the engine in my Xterra has 230k miles on it - I've got leaking valve covers, low oil pressure from a galley gasket, and a clicking noise that I think it related to my valve lashing. I have a spare VQ40 in the shop with 85k miles on it. It will be faster for me to just swap...
Top