Second Generation Nissan Xterra Forums banner

Discussions Showcase Albums Media Media Comments Tags

1-8 of 8 Results
  1. Electrical
    I had no problems with my automatic X until a few days ago, at first it worked. Went to school and came back. The next day it had a hard crank but started up later in the day turning it on, the dash lights flickered and the crank sounded like a machine gun ratata clicking. Decided I should jump...
  2. General Xterra
    I own a 2005 Xterra SE, and when I bought it, the radio didn’t work. Upon further inspection, I found out the fuse keeps blowing (pull out the old one, put in the new one and boom, it’s blown). Not sure what the issue is, unplugged the radio and put new fuse in, doesn’t blow until I plug the...
  3. Electrical
    Ok so I used to store my 07 X at my buddy’s property with the shop and nearby trails, but I parked her 4 months ago in my driveway because it has had an overheating problem even though it was not leaking/losing any coolant and has now basically had a cooling system overhaul (radiator + caps...
  4. Electrical
    I first got the code shortly after I got my 2011 Xterra about 2 years ago so I bought a new aftermarket sensor. The SES light stayed off for awhile but its been returning frequently. I clean it and re-install it and the light stays off for about 2 weeks then comes back on. I have a mechanic...
  5. Electrical
    2011 Xterra Pro-4X, 137k miles - in the past 3 months I have been getting intermittent MAF codes that seem to come and go with no performance issues to speak off. Recently, the orange back lighting of the dash has begun to flicker and this morning, as I was driving 25mph, the electrical power...
  6. Electrical
    So my battery just died out of nowhere… I posted previously about replacing the camshaft/crankshaft sensors and now I’m seemingly having another electrical issue. Last night randomly after being in the grocery store for about 15 minutes I came out and it wouldn’t start… The battery is less...
  7. Powertrain & Driveline
    Hope everyone is staying safe, after getting a bit of cabin fever I decided to hit up a local trail since there had been a good rain recently. Water was decently high in one part especially and I may have hit it a bit too hard (who doesn’t love splashing giant mud puddles) Anyways on my way...
  8. Electronics
    Hi there, I have a 2002 xterra with an after market sony XAV-AX1000 head unit and am having the problem of no sound coming from the speakers. The two rear speakers were both blown when I got the car and so I have always just used the two front door speakers and A pillar tweeters to play music...
1-8 of 8 Results
Top