What Have You Done for Your X Lately? - Page 2824 - Second Generation Nissan Xterra Forums (2005+)
 7098Likes
 
LinkBack Thread Tools Display Modes
post #28231 of 28479 (permalink) Old 05-15-2019, 05:43 PM
Senior Member
2005 Silver Lightning Xterra SE 4x4 5AT
 
Adam12SD's Avatar
 
Join Date: Feb 2018
Location: El Cajon, CA
Posts: 463
Quote:
Originally Posted by Longboardr View Post
Good man, that's a chit ton of work. I bought and used a BISSELL SpotClean ProHeat on the X last summer, couldn't be happier with the results.
Yuuuup. I have a Bissell with the wand and it works wonders. Haven't shampooed the X yet, but I'm looking forward to it.
Longboardr likes this.
Adam12SD is online now  
Sponsored Links
Advertisement
 
post #28232 of 28479 (permalink) Old 05-15-2019, 08:54 PM
Senior Member
2012 Xterra X
 
Join Date: Jan 2017
Location: Willis, TX
Posts: 181
Over the last two days ,I've been installing a 10" sub and amp after work, finished it up and thinking it's too much bass

Sent from my ONEPLUS A6013 using Tapatalk
Adam12SD likes this.
Battousaited is offline  
post #28233 of 28479 (permalink) Old 05-16-2019, 01:44 AM
TNX Realm Noobie
2006 Knight Armour Xterra Off Road
 
Join Date: Feb 2019
Location: Victoria, BC, Canada
Posts: 17
Modded some brackets tonight to make the aftermarket head unit sit a bit better. It's quite deep, so once I added the RCA connectors in the back it was colliding with an unused steel bracket. Nothing a dremel couldn't fix. I also modded the stereo mount brackets to make it sit a bit further out and I'm much happier with the look now. Still fighting with ground loop pops despite trying to ground to various spots around the vehicle so I've ordered some ground loop isolators to fix the issue (thanks @meisanerd for the suggestion). Saw some sparks fly as I was hooking up the ground of the stereo so I'm wondering if there's something else going on. I'll have to measure the potential between the grounds next time I pull it out.

Also insured the X and drove her in to work today! First time she's been on the road since I bought her a month ago.
TerryD and Adam12SD like this.
Solarisphere is offline  
 
post #28234 of 28479 (permalink) Old 05-16-2019, 12:07 PM
TNX Realm Noobie
2006 Xterra SE
 
Join Date: Jul 2017
Location: Anaconda, MT
Posts: 41
Radiator replacement, headlight restoration, some fixing of unprofessional collision repairs. Possibly going to check out the Katana LED headlight bulbs and maybe a light bar in the mouth of the bumper. Bumper and grille are off so might as well rhino line those while I'm at it. I'm glad I got my back-up vehicle running right so I can have the X ripped apart for a little while.
mtnbound likes this.
KenHurst is offline  
post #28235 of 28479 (permalink) Old 05-16-2019, 02:13 PM
Member
2005 Super Black Xterra Off Road 6MT
 
Firehawk989's Avatar
 
Join Date: Feb 2019
Location: Vancouver, BC, Canada
Posts: 69
Garage
Used the wet box for what I can only assume is its true intended use; tossing a wetsuit in after a day of surfing! Also first time putting anything on the roof rack, and made good use of the hitch towing this cool little trailer. Somehow managed nearly 17mpg pulling the trailer, probably because the speed limits were mostly 80-90km/h and not too many hills.
Attached Images
File Type: jpg IMG_20190508_145255_1558029978028.jpg (4.45 MB, 73 views)
File Type: jpg IMG_20190510_131629_1558030060358.jpg (7.16 MB, 72 views)
DATW, 4funX and Adam12SD like this.

Last edited by Firehawk989; 05-16-2019 at 02:16 PM.
Firehawk989 is offline  
post #28236 of 28479 (permalink) Old 05-16-2019, 03:02 PM
Lifetime Premium Member
2010 Midnight Armor ❌terra X
 
MeHere!'s Avatar
 
Join Date: Feb 2018
Location: Somerville, MA
Posts: 220
Garage
Quote:
Originally Posted by Firehawk989 View Post
Used the wet box for what I can only assume is its true intended use; tossing a wetsuit in after a day of surfing! Also first time putting anything on the roof rack, and made good use of the hitch towing this cool little trailer. Somehow managed nearly 17mpg pulling the trailer, probably because the speed limits were mostly 80-90km/h and not too many hills.
But....is it an XTERRA wetsuit??
GDPearson, TANSTAAFB and Adam12SD like this.

"Well, my time of not taking you seriously is coming to a middle."

Click Here for >
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MeHere! is offline  
post #28237 of 28479 (permalink) Old 05-16-2019, 03:04 PM
Senior Member
2005 Silver Lightning Xterra SE 4x4 5AT
 
Adam12SD's Avatar
 
Join Date: Feb 2018
Location: El Cajon, CA
Posts: 463
Quote:
Originally Posted by Firehawk989 View Post
Used the wet box for what I can only assume is its true intended use; tossing a wetsuit in after a day of surfing! Also first time putting anything on the roof rack, and made good use of the hitch towing this cool little trailer. Somehow managed nearly 17mpg pulling the trailer, probably because the speed limits were mostly 80-90km/h and not too many hills.
That's a neat looking trailer! I've always had an eye for the retro look.
Adam12SD is online now  
post #28238 of 28479 (permalink) Old 05-16-2019, 03:08 PM
Member
2010 Silver Lightning Xterra Off Road
 
TANSTAAFB's Avatar
 
Join Date: Jan 2018
Location: Dallas, TX
Posts: 83
Quote:
Originally Posted by Firehawk989 View Post
Used the wet box for what I can only assume is its true intended use; tossing a wetsuit in after a day of surfing! Also first time putting anything on the roof rack, and made good use of the hitch towing this cool little trailer. Somehow managed nearly 17mpg pulling the trailer, probably because the speed limits were mostly 80-90km/h and not too many hills.
Damn! I get about 8-9 mpg hauling an ultralight [email protected]

Where were you playing?

Sent from my Pixel 2 using Tapatalk
TANSTAAFB is offline  
post #28239 of 28479 (permalink) Old 05-16-2019, 03:43 PM
Member
2005 Super Black Xterra Off Road 6MT
 
Firehawk989's Avatar
 
Join Date: Feb 2019
Location: Vancouver, BC, Canada
Posts: 69
Garage
Quote:
Originally Posted by MeHere! View Post
Quote:
Originally Posted by Firehawk989 View Post
Used the wet box for what I can only assume is its true intended use; tossing a wetsuit in after a day of surfing! Also first time putting anything on the roof rack, and made good use of the hitch towing this cool little trailer. Somehow managed nearly 17mpg pulling the trailer, probably because the speed limits were mostly 80-90km/h and not too many hills.
But....is it an XTERRA wetsuit??
Sadly no, it was a ripcurl I believe. (Rented it because mine isn't warm enough for this early in the season.)

Quote:
Originally Posted by TANSTAAFB View Post
Quote:
Originally Posted by Firehawk989 View Post
Used the wet box for what I can only assume is its true intended use; tossing a wetsuit in after a day of surfing! Also first time putting anything on the roof rack, and made good use of the hitch towing this cool little trailer. Somehow managed nearly 17mpg pulling the trailer, probably because the speed limits were mostly 80-90km/h and not too many hills.
Damn! I get about 8-9 mpg hauling an ultralight [email protected]

Where were you playing?

Sent from my Pixel 2 using Tapatalk
Yeah I was very surprised as it was actually the best overall mileage I've gotten with the X so far period. I think the main factor was the low speeds. I seem to normally get closer to 15 or 16mpg at 120km/h on the hilly highway going to visit my folks.

As for the play spot, we spent last week camping in Pacific Rim National Park on the West coast of Vancouver Island!
MeHere! likes this.
Firehawk989 is offline  
post #28240 of 28479 (permalink) Old 05-16-2019, 03:52 PM
Veteran
2006 Avalanche White Xterra S 4x4
 
Join Date: May 2016
Location: Aurora, CO
Posts: 1,332
Quote:
Originally Posted by Battousaited View Post
Over the last two days ,I've been installing a 10" sub and amp after work, finished it up and thinking it's too much bass

Sent from my ONEPLUS A6013 using Tapatalk
Its amazing what a properly set up 10" woofer can do, back in HS when some of my friends had systems i noticed that the folks with 10"s sounds better than the ones with 12". the 12"s were maybe louder but more muffled sounding.
mtnbound is offline  
Reply

  Second Generation Nissan Xterra Forums (2005+) > General Topics > General Xterra

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Second Generation Nissan Xterra Forums (2005+) forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome