What Have You Done for Your X Lately? - Page 2754 - Second Generation Nissan Xterra Forums (2005+)
 7403Likes
 
LinkBack Thread Tools Display Modes
post #27531 of 28746 (permalink) Old 01-26-2019, 06:16 PM
Lifetime Premium Member
2007 Midnight Blue ❌terra S
 
TerryD's Avatar
 
Join Date: Jul 2016
Location: Covington, VA
Posts: 2,065
Garage
Picked up a piece of 3/4" aluminum square tube for the new radio mount under the passenger seat. My wife took the elder minion and the little one with her to help her sister move this weekend so me and the Monkey have been playing today. We went out to breakfast and did some shopping. We've played video games, watched movies, ate sushi and McDonalds and even went on a little walk/run.

I'm trying to get into better shape and she likes to go out walking/hiking with me and I'm hoping she'll push me to get out and go.
GDPearson and caain like this.

Mildly Demented...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

KT4OZ
Build Thread:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TerryD is online now  
Sponsored Links
Advertisement
 
post #27532 of 28746 (permalink) Old 01-26-2019, 06:23 PM
Veteran
2010 Super Black Xterra Off Road
 
Un4seen4's Avatar
 
Join Date: May 2014
Location: Boise, Idaho
Posts: 2,101
Quote:
Originally Posted by PhullD View Post
How did you decide to trim the fenders? Body lift or no?
no body lift, I have a ton of pics ill try and post later today
PhullD and GDPearson like this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-IG-x.treks- "No one can deny the pure flex of Un4seen4" - AlbatrossCafe
Un4seen4 is online now  
post #27533 of 28746 (permalink) Old 01-26-2019, 07:41 PM
Veteran
2011 Super Black Xterra S Plus
 
NYTKSHR's Avatar
 
Join Date: Mar 2011
Location: Las Vegas, NV
Posts: 2,230
Quote:
Originally Posted by GPD605X View Post
Changed out the very worn poly bushings and noticed some issues with the passenger leaf pack...


Just as a matter of interest are those Nisstech shackles? If so you may want to straighten them out and add a washer or 2 on either side of the bushing as I expect it is the fact then are pinched at the bottom and very loose at the top as the reason it ate your bushings.

Click Here for >
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NYTKSHR is offline  
 
post #27534 of 28746 (permalink) Old 01-26-2019, 07:50 PM
Veteran
2007 Super Black Xterra S Titan Swapped!
 
GPD605X's Avatar
 
Join Date: Apr 2010
Location: Gulfport, MS
Posts: 3,899
Garage
Quote:
Originally Posted by NYTKSHR View Post
Just as a matter of interest are those Nisstech shackles? If so you may want to straighten them out and add a washer or 2 on either side of the bushing as I expect it is the fact then are pinched at the bottom and very loose at the top as the reason it ate your bushings.
I honestly can't tell ya. These shackles were on it when I got it. We had to hammer the Sh1t out of them just to put them back in and ended up cutting one of them in the process.

Quote:
Originally Posted by T-REXterra View Post
"100% of people with snorkels have bigger wieners than those without snorkels."
-Abraham Lincoln

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
GPD605X is offline  
post #27535 of 28746 (permalink) Old 01-26-2019, 09:59 PM
Veteran
2013 Super Black Xterra Pro-4X
 
IssacHunter's Avatar
 
Join Date: Nov 2016
Location: Grundy, VA
Posts: 1,673
Garage
Installed an oil catch can into the X today.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Nissan Off-Roaders of the SouthEast (N.O.R.S.E.), Virginia Xterra Club (VAXC)
OverlandBound member #16797 "Adventr-X" Adventure is necessary.
IssacHunter is offline  
post #27536 of 28746 (permalink) Old 01-27-2019, 01:30 AM
Senior Member
 
Join Date: Nov 2006
Location: Louisville, KY
Posts: 201
Since doing some repairs on my wife’s Xterra over the holidays I noticed the factory speakers were shot. Today I finished installing all new speakers, a new headunit, and a bonnet strut kit for a Navara off of eBay. I think I’ve spent the money I saved on her Cat repair now. Ha!
eighty and FLAX like this.

2006 Midnight Blue
Xterra 4X4 S
Graytshirt is offline  
post #27537 of 28746 (permalink) Old 01-27-2019, 02:54 PM
TNX Realm Noobie
2013 Knight Armor Xterra Pro-4X
 
Comisar's Avatar
 
Join Date: Aug 2017
Location: Tallahassee, FL
Posts: 18
Garage
Put a new battery in, went with a Bosch Platinum AGM 24f. I had drained my battery a few weeks ago by accidentally leaving my ham radio on, thought I had an auto turn off programmed on it. Battery wasn't quite the same since, pep boys said it was at 0% health.

Also removed the K&N CAI that came with my X and installed the OEM intake. I don't think whoever put the K&N on did it right, it wasn't very stable, one of the bolts had sheared off and the filter had been rubbing on the frame. It had worn a hole through the cover and dented the filter itself. I was hoping I'd be able to sell it once I got around to replacing it, but I don't think I can now.

And when I was installing the OEM air box, the weld nut closest to the front broke off. It still feels pretty stable once it's all closed up, but is that something I should try to fix?
Attached Images
File Type: jpg MVIMG_20190126_180303.jpg (138.1 KB, 30 views)
File Type: jpg IMG_20190126_180246.jpg (100.6 KB, 31 views)
Comisar is offline  
post #27538 of 28746 (permalink) Old 01-28-2019, 12:37 AM
Veteran
2010 X
 
Join Date: Nov 2013
Location: Vancouver, BC
Posts: 741
Quote:
Originally Posted by Graytshirt View Post
Since doing some repairs on my wifeís Xterra over the holidays I noticed the factory speakers were shot. Today I finished installing all new speakers, a new headunit, and a bonnet strut kit for a Navara off of eBay. I think Iíve spent the money I saved on her Cat repair now. Ha!


Which speakers did you go for? Plug and play?


Sent from my iPhone using Tapatalk
eighty is offline  
post #27539 of 28746 (permalink) Old 01-28-2019, 01:25 AM
Veteran
2005 Super Black Xterra OR
 
Wanderer's Avatar
 
Join Date: Oct 2012
Location: San Francisco Bay Area
Posts: 616
Winch winch baby.

20190126_114436.jpg
scoyoc and Adam12SD like this.

Last edited by Wanderer; 01-28-2019 at 01:32 AM.
Wanderer is offline  
post #27540 of 28746 (permalink) Old 01-28-2019, 01:52 AM
Senior Member
2005 Silver Lightning Xterra SE 4x4 5AT
 
Adam12SD's Avatar
 
Join Date: Feb 2018
Location: El Cajon, CA
Posts: 495
Quote:
Originally Posted by Wanderer View Post
Winch winch baby.



Attachment 108790
Neat! Which winch [emoji3061] mount did you use?

Sent from my SM-G965U using Tapatalk
Adam12SD is offline  
Reply

  Second Generation Nissan Xterra Forums (2005+) > General Topics > General Xterra

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Second Generation Nissan Xterra Forums (2005+) forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome