Second Generation Nissan Xterra Forums (2005+) - View Single Post - General Tarfun's X
View Single Post
post #84 of (permalink) Old 05-18-2019, 10:48 PM
SledheadX
Senior Member
2012 Super Black Xterra Pro-4X
 
SledheadX's Avatar
 
Join Date: Jan 2019
Location: Rochester, NY
Posts: 172
Garage
Quote:
Originally Posted by General_Tarfun View Post
OH and how could I forget that 'other' thing I did today. I've been having front end issues with popping and the steering being jerked around. Looked at a bunch of options and decided to just pull the front sway bar first, worst case was the links were shot and I'd have to replace them anyway. Well the 8 month old POS Mevotech endlinks are totally shot, I moved the boot around and the sockets are full of rust, just total junk but the big surprise was holy sh*$ the truck drives nicely now. It's like driving someone else's truck! I took a quick drive down some of the winding, bumpy roads nearby that I'm on daily just to see how it handles now and its like a dream, I love it. The suspension is so soft now, no more fighting the steering to keep the truck going straight, small bumps feel like the nothing that they are, and I don't notice any extra sway from it. It's weird but the sway bar basically was blocking the front suspension from being a suspension. Night and day difference, I'll keep the sway bar in storage but zero chance I'm reinstalling it.
Great!!! Glad it was a simple solution. Better than changing suspension settings for sure. You're now another instigator for me to rip mine off.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AWW FRELL!!!
SledheadX is offline  
 
 
For the best viewing experience please update your browser to Google Chrome